Results 1 to 3 of 3

Thread: [grub] DEFAULT=saved causing mishap

  1. #1
    Join Date
    Oct 2020
    Beans
    3

    Post [grub] DEFAULT=saved causing mishap

    Just installed Ubuntu 20.04 but changed the sata cable and it's not working anymore,

    tried reinstalling but the problem persists for all changes in disks i add and grub can't recognize as filesystems.

    Should i try to disable DEFAULT=savedor GRUB_SAVEDEFAULT=true before trying to boot kernel from root=(hd0,msdos2)?

  2. #2
    Join Date
    May 2013
    Location
    Galiza
    Beans
    2,881
    Distro
    Ubuntu

    Re: [grub] DEFAULT=saved causing mishap

    Perhaps you need to change the boot order to the drive where it was installed originally?
    The order in BIOS or UEFI was changed when you changed the cable... Not that just replacing a cable would do that but in reality you connected it in another port, didn't you?

  3. #3
    Join Date
    Oct 2020
    Beans
    3

    Thumbs up Re: [grub] DEFAULT=saved causing mishap

    Already solved. i've used the next grub command
    set root=(ahci0,msdos2)
    and then
    insmod normal.mod
    then reinstalled grub to the prior version.
    also couldn't find the new grub terminal so did
    insmod help
    and
    insmod fshelp.
    i still can't see all modules on screen i think i need read more grub2 docs

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •