Results 1 to 2 of 2

Thread: Cannot enter accented characters in GNU Emacs

  1. #1
    Join Date
    Aug 2013
    Beans
    29

    Cannot enter accented characters in GNU Emacs

    Hi,
    This issue persists for years without any resolution. If I start GNU Emacs from the start menu or by hitting ALT-F2 and typing emacs, the text editor cannot enter any accented character. Hitting ` followed by e just displays e, not è. Same thing for ç, ê, à, etc. The only workaround is to start Emacs with XMODIFIERS="" emacs from a terminal window. I was able to improve this workaround by putting the export XMODIFEIRS="" into my .bashrc, but that stopped working a week ago. Now the only way is to start emacs from a terminal; I cannot start it from the start menu or the ALT-F2 "Run program" box, which I'm used to do, do and redo, and have to restart Emacs from a terminal to get accented characters. I tried running sudo im-config and set the input method to none: no effect, even after restarting Ubuntu.

    I am running Ubuntu 20.04 MATE with the latest updates.

    There was a thread about this: https://ubuntuforums.org/showthread.php?t=2183796. Instead of bringing a solution, somebody locked the thread so no replies can be posted anymore. This way, the problem looked to be solved but is still there. Is it because I need to get paid support for Ubuntu now, to get such issues solved? Yes, I could work around this by rebooting to Windows, but what's the point of having Linux in dual boot if I have to reboot to Windows pretty much for everything except Firefox? That kind of makes no sense.

    Please don't lock the thread if it is inappropriate; remove it and tell me why. Google indexes all the threads on the forum so when people search, they find the locked threads and cannot get to a real solution, only loose time searching and reading "bump", "i have the same issue", etc.

  2. #2
    Join Date
    May 2008
    Beans
    1,034
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Cannot enter accented characters in GNU Emacs

    Just to satisfy my curiosity, can you try:

    Press Alt Gr and Semi-colon simultaneously, release then press a

    Do you get á?

    Alternatively:

    Scroll Lock and apostrophe (or single quote) also simultaneously, release and press a

    Do you get á?

    I don't know about EMACS but they work in in other applications such as Gedit, LibreOffice, Thunderbird and in this forum.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •