I recently acquired an Acer Spin 3 SP314-54N, it is a great laptop however i'm rather a big fan of linux so very soon after i got it i installed ubuntu on here (my end goal was kubuntu but i had a usb with ubuntu laying around) after messing around with the storage mode, switching from intel RST to AHCI, it worked and booted up smooth, however neither my touchscreen or trackpad work. I managed to fix the trackpad by changing the trackpad mode from IC2 to PS2 however the touchscreen still doesn't work because from what i've looked up the touchscreen is reliant on IC2 (i think i'm not sure), someone with the bigger brother to my laptop, the spin 5 managed to fix it by entering in "i8042.nopnp=1 pci=nocrs", that might not be precisely it as i just read it off a scribbled note, they put it into the grub when they booted it up, inbetween "splash" and "_ _ _", which i can't find when i go to the grub menu and press e on the grub, i'm pretty stuck and it would be a bummer not being able to use the touchscreen.


p.s. i've tried different kernels my current one is the default Kubuntu kernel 5.4.0-42-generic