Results 1 to 6 of 6

Thread: Cannot boot in UEFI mode with Secure Boot disabled from 20.04.1 Live USB

  1. #1
    Join Date
    Apr 2018
    Beans
    9

    Exclamation Cannot boot in UEFI mode with Secure Boot disabled from 20.04.1 Live USB

    Hello,

    I cannot boot the live usb when bios is set up in UEFI mode with secure boot disabled. As soona as I press enter on the grub entry, the system freezes and remains at a black screen (I can see the lights on my keyboard and mouse turning off).

    I can however boot in CSM + Uefi/Legacy.

    I have run the
    Code:
    boot-repair
    utility in the live USB environment but it refuses to apply any changes as it says UEFI mode is required.

    A dump of the current boot configuration as generated by
    Code:
    boot-repair
    can be located here:

    HTML Code:
    http://paste.ubuntu.com/p/XfCfkyhzfp/
    System config:
    AMD Ryzen 3600X
    MSI B450 Tomahawk Max
    MSI Nvidia GTX 1080 TI
    32 GB
    Dual boot Ubuntu and Windows 10


    Prior to trying to boot the 20.04.1 live cd I did have an working install of 18.04.1 with the 5.7 kernel. That installation presents the very similar symptoms after the upgrade: no matter what kernel entry I choose, being it either normal or recovery, I end up with a black screen and system soft freeze.

    I've tried adding
    Code:
    nomodeset
    to the grub entry in the menu but no success. I've attached a photo of the grub entry.

    Any suggestions?

    LE: Same issue with 18.04 Live USB.
    Attached Images Attached Images
    Last edited by tugurlann; September 23rd, 2020 at 10:15 PM.

  2. #2
    Join Date
    Mar 2011
    Beans
    1,644

    Re: Cannot boot in UEFI mode with Secure Boot disabled from 20.04.1 Live USB

    Have you checked for and applied any firmware updates for the B450 motherboard?

  3. #3
    Join Date
    Sep 2011
    Location
    Pennsylvania, U.S.A.
    Beans
    2,944
    Distro
    Ubuntu Development Release

    Re: Cannot boot in UEFI mode with Secure Boot disabled from 20.04.1 Live USB

    Quote Originally Posted by ubfan1 View Post
    Have you checked for and applied any firmware updates for the B450 motherboard?
    This is a very good point. Often motherboards will require a certain BIOS version or newer in order to boot Ryzen 3rd generation processors. Your motherboard vendor's web site should have pertinent information.

  4. #4
    Join Date
    Apr 2018
    Beans
    9

    Re: Cannot boot in UEFI mode with Secure Boot disabled from 20.04.1 Live USB

    I have the latest bios.

    However, it was fixed as I decided on a whim to reset bios to factory defaults and then re-eanbled uefi boot without secure boot.

    Everything is working right now. I assume some kind of firmware glitch but I don't have the means to debug it. I will put in my settings one by one and see if and where linux will hang again.

  5. #5
    Join Date
    May 2013
    Location
    Galiza
    Beans
    2,902
    Distro
    Ubuntu

    Re: Cannot boot in UEFI mode with Secure Boot disabled from 20.04.1 Live USB

    Many firmwares, past and present, BIOS or UEFI, have had similar "glitches". Reset to defaults was and is a procedure to solve most cases ideed.

  6. #6
    Join Date
    Apr 2018
    Beans
    9

    Re: Cannot boot in UEFI mode with Secure Boot disabled from 20.04.1 Live USB

    Everything is in order, I have put the bios settings to before the reset and all is in order.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •