Results 1 to 4 of 4

Thread: Samsung printer suddenly prints gibberish

  1. #1
    Join Date
    Jun 2014

    Samsung printer suddenly prints gibberish

    I'm running Ubuntu 18.04, and a Samsung M270 printer. I am using the drivers for that printer downloaded from the Samsung web site.

    I was printing letters. One printed perfectly. The other printed in gibberish. The original one now prints in gibberish too.

    By gibberish I mean endless pages each with a row of rectangles at the top.

    I tried uninstalling the printers and reinstalling them, redownloading the driver, and reinstalling it.

    It's still printing in gibberish.

    How do I fix it?


  2. #2
    Join Date
    Aug 2006
    gypsy encampment
    Lubuntu 18.04 Bionic Beaver

    Re: Samsung printer suddenly prints gibberish

    Since no-one else has had any input, I'll try to share what little I know. First, it appears that you have been doing what Ubuntu documentation suggests for Samsung printers (other than use something else) which is to use the manufacturers drivers. Since that was working an no longer does, it would appear something has changed - maybe an update? One thing you could try is booting from a previous kernel to see if that changes things:

    If that doesn't work for you, you might have to use CUPS (Common Unix Printing System):

    I had to do this for an antique Samsung laser printer (it still had a parallel port!).
    Reminder: If you start a thread asking for help with a problem, please remember to use the Thread Tools to mark the issue as "SOLVED" once you have a solution. This will help other people with the same problem when they search for answers.

  3. #3
    Join Date
    Mar 2010

    Re: Samsung printer suddenly prints gibberish

    Bad usb connection or cable? reseat both sides?
    I have a samsung laser printer that has been working since 2006-ish, but it gets used for less than 200 pgs a year.

  4. #4
    Join Date
    Sep 2011
    Pennsylvania, U.S.A.
    Ubuntu Development Release

    Re: Samsung printer suddenly prints gibberish

    I have a Samsung Xpress 2870(?) that will print gibberish - one or two lines of random characters per page and will continue until the paper is exhausted if I use "driverless" printing. The latest driver from HP's support site works as expected so far. That is not working for you but my Samsung also 'speaks' PCL5 I think, so some sort of LaserJet emulation. Maybe try that?

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts