Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: my multiple os desktop computer is not having the option to load fedora at startup

  1. #11
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,778

    Re: my multiple os desktop computer is not having the option to load fedora at startu

    but i still can't monut sda8.
    You can't mount sda8 since it's an LVM physical volume. You would need to know the LV path for Fedora's root logical volume to mount it. You can use sudo lvdisplay to find the LV Path.

    Then you can mount it using this construct:
    Code:
    sudo mount LV-path mount-point

  2. #12
    Join Date
    Jan 2017
    Beans
    241

    Re: my multiple os desktop computer is not having the option to load fedora at startu

    ok
    but do you think that i need to follow:
    https://ubuntuforums.org/showthread....2#post13733372
    for mounting it? because with the sudo apt-get install lvm2 i could not mount it in the file manager as it is not seen there.

    i also not sure how to use the 'sudo mount /dev/YourVolGroup00/YourLogVol00 /YourMountPoint' command. what should i fill in "YourVolGroup00/YourLogVol00 /YourMountPoint"
    i'm attaching the results of all the commands except for the last one:
    https://pastebin.com/9k17zn7w


    edit:
    i've now rebooted and it's working. fedora is shown and i i'm using it now.
    i'm wondering how exactly can i use the fedora's grub so it doesn't happens again.
    thanks

    you really helped me and saved me from installing fedora again.
    Last edited by ronjjjg8885; 4 Weeks Ago at 09:34 AM.
    my desktop computer has Ubuntu 20.04.1 LTS 64bit alongside with fedora and windows 10 as multiple boot
    my laptop is with Ubuntu 20.04.1 LTS 64bit {only}

  3. #13
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,778

    Re: my multiple os desktop computer is not having the option to load fedora at startu

    i'm wondering how exactly can i use the fedora's grub so it doesn't happens again.
    You don't need to do anything with Fedora's grub, such as reinstall it.

    With UEFI, the listing order in the UEFI boot manager determines which OS boots at startup. You can change that in the UEFI firmware (sometimes called 'UEFI BIOS') and put Fedora first. Look in the boot settings in the UEFI.

    When Ubuntu upgrades or reinstalls grub, it changes that boot order to put Ubuntu first. That's what happened here. BTW, Fedora doesn't change this order when it upgrades its grub.
    Last edited by Dennis N; 4 Weeks Ago at 12:28 PM.

  4. #14
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: my multiple os desktop computer is not having the option to load fedora at startu

    Most systems will let you change boot order with efibootmgr.
    A few only seem to work if you change in UEFI as Dennis N has explained.

    Check current order & hex number of each entry:
    sudo efibootmgr -v
    Change boot order with efibootmgr, some require all 4 hex char others 1 is ok.
    sudo efibootmgr -o 0,1,2
    see also
    man efibootmgr
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  5. #15
    Join Date
    Jan 2017
    Beans
    241

    Re: my multiple os desktop computer is not having the option to load fedora at startu

    Tnx !
    my desktop computer has Ubuntu 20.04.1 LTS 64bit alongside with fedora and windows 10 as multiple boot
    my laptop is with Ubuntu 20.04.1 LTS 64bit {only}

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •