Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: No microphone input signal while sound still works

  1. #11
    Join Date
    Sep 2020
    Beans
    11

    Re: No microphone input signal while sound still works

    Quote Originally Posted by gdesilva View Post
    Note that there is a bug report on no sound on Samsung chromebooks which may or may not be similar to your issue

    https://www.mail-archive.com/kernel-...msg398292.html

    Sorry cannot be of any further help.

    It may be, though from what I've seen it does not deal with mic in particular. Again, thanks for the suggestion. At at least now I'm fully convinced that that the soundcard on Sumsung chromebooks is ass)

    Also, the issue might be connected with system seeing two soundcards. Few minutes ago I attempted to use
    alsamixer -c 0 sset 'Mic',0 100% cap unmute
    alsamixer -c 0 sset 'Mic Boost (+20dB)',0 on

    and the result was that alsamixer displayed the mixer for HDA Intel PCH with no parameters being modifiable instead of chtrt5650.
    here's how it looked like: https://imgur.com/Q0dVBEs.png
    Last edited by staskhudzik; 3 Weeks Ago at 03:08 AM.

  2. #12
    Join Date
    Nov 2009
    Beans
    333
    Distro
    Ubuntu Studio 20.04 Focal Fossa

    Re: No microphone input signal while sound still works

    According to lspci there is only one sound device which is HDA Intel PCH. I may be wrong here but Braswell HDMI refers to this sound device built in on the Braswell mobo.

    Is there a separate HDMI IN port on your system?

    EDIT: check that you have defined the correct profile for the HDMI Audio - if it can handle two way (both output and input) then the profile should be something like Digital Stereo Duplex in pavucontrol->Configuration
    Last edited by gdesilva; 3 Weeks Ago at 07:38 AM.
    __________________________________________________ ______________________________________
    Sent from my iSomething running Linux - safe, fast and it is free! Didn't have to pay for the badge

  3. #13
    Join Date
    Nov 2009
    Beans
    333
    Distro
    Ubuntu Studio 20.04 Focal Fossa

    Re: No microphone input signal while sound still works

    Did a bit of digging into these Chromebooks and it appears that audio on these things running Linux is a known problem. As MrChromebox says, "Then you have to deal with potentially porting functionality/drivers from ChromeOS to the upstream Linux kernel, because there's zero chance everything works out of the box (especially audio)." in https://www.reddit.com/r/chromeos/co...xy_chromebook/
    __________________________________________________ ______________________________________
    Sent from my iSomething running Linux - safe, fast and it is free! Didn't have to pay for the badge

  4. #14
    Join Date
    Sep 2020
    Beans
    11

    Re: No microphone input signal while sound still works

    Quote Originally Posted by gdesilva View Post
    According to lspci there is only one sound device which is HDA Intel PCH. I may be wrong here but Braswell HDMI refers to this sound device built in on the Braswell mobo.

    Is there a separate HDMI IN port on your system?

    EDIT: check that you have defined the correct profile for the HDMI Audio - if it can handle two way (both output and input) then the profile should be something like Digital Stereo Duplex in pavucontrol->Configuration

    What do you mean by "on my system"? According to pavucontrol my profile was stereo output + multi-channel input. I tried switching it to multi-channel duplex but nothing really changed.

  5. #15
    Join Date
    Nov 2009
    Beans
    333
    Distro
    Ubuntu Studio 20.04 Focal Fossa

    Re: No microphone input signal while sound still works

    What I meant was whether you have two HDMI ports, HDMI IN and HDMI out - unlikely but thought of checking it anyway.

    Perhaps, someone with experience with Chromebooks can suggest a solution or a workaround this issue.
    __________________________________________________ ______________________________________
    Sent from my iSomething running Linux - safe, fast and it is free! Didn't have to pay for the badge

  6. #16
    Join Date
    Sep 2020
    Beans
    11

    Re: No microphone input signal while sound still works

    Quote Originally Posted by gdesilva View Post
    What I meant was whether you have two HDMI ports, HDMI IN and HDMI out - unlikely but thought of checking it anyway.
    I have a one port.

    Today I decided to mess with alsamixer a bit more and tried unmuting everything possible. After the operation the mic turned on but with an extremely loud hiss. I started tweaking knobs to figure which one was responsible for mic and somehow messed the whole sound. Now even output signal is off, in the pavucontrol there are only dummy input and output and the sound does not react to alsamixer at all.
    The good thing that after upgrade alsamixer allows to display multiple parameters in terminal. Now, however, this is not a big help, I guess(

  7. #17
    Join Date
    Nov 2009
    Beans
    333
    Distro
    Ubuntu Studio 20.04 Focal Fossa

    Re: No microphone input signal while sound still works

    If I were you, I would try re-installing alsa sound but given there appears to be an underlying issue with sound on Chromebooks it may not fix your issue - still worth a try now that it is all broken anyway!
    __________________________________________________ ______________________________________
    Sent from my iSomething running Linux - safe, fast and it is free! Didn't have to pay for the badge

  8. #18
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    21,307
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: No microphone input signal while sound still works

    I've had 2 chromebooks. Put ubuntu on both. Sound always worked on both, though did use a usb mic to get better input audio for recordings. The audio jack on my toshiba chromebook was always a mystery. The usb mic solved all sorts of issues for me. Samson GoMic.

    Never had any special audio issues with my Haswell 2995U chromebook.
    Never had any special audio issues with my Broadwell 5015U chromebook.

    The only issue I had with either was low RAM (expected on chromebooks) and 10-ish dead keys after about 2 yrs of daily use. The keyboards on these things just can't take my typing.
    Last edited by TheFu; 2 Weeks Ago at 03:12 PM.

  9. #19
    Join Date
    Sep 2020
    Beans
    11

    Re: No microphone input signal while sound still works

    Quote Originally Posted by gdesilva View Post
    If I were you, I would try re-installing alsa sound but given there appears to be an underlying issue with sound on Chromebooks it may not fix your issue - still worth a try now that it is all broken anyway!
    You know, the funny thing is that de-installing and re-installing alsa-utils did not work, as alsa force-reload and replacing asound.state, BUT alsa force-unload did actually help restore alsamixer parameters and I was able to return the output sound. However, I still can't understand which parameter in alsamixer is responsible for mic sound and now I know that attempting at straight up unmuting everything risks messing the whole sound configuration.

  10. #20
    Join Date
    Nov 2009
    Beans
    333
    Distro
    Ubuntu Studio 20.04 Focal Fossa

    Re: No microphone input signal while sound still works

    Have you tried https://alsa.opensrc.org/ ?

    EDIT : Check out this post https://bbs.archlinux.org/viewtopic.php?id=252123 - read the second and the last post by uhmzilighase. The problem is not identical to yours but it is claimed that only certain versions of alsa packages work on Braswell.
    Last edited by gdesilva; 2 Weeks Ago at 08:08 AM.
    __________________________________________________ ______________________________________
    Sent from my iSomething running Linux - safe, fast and it is free! Didn't have to pay for the badge

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •