Results 1 to 9 of 9

Thread: Ubuntu 20 showing filesystem check hence taking too long to boot

  1. #1
    Join Date
    Aug 2020
    Beans
    17

    Ubuntu 20 showing filesystem check hence taking too long to boot

    I installed Ubuntu 20 on a system with per-installed windows 10 Now every time I boot up to Ubuntu I get a filesystem checking message with a busy logo and takes long time to boot here is the log:

    systemd-analyze:

    Code:
    Startup finished in 9.099s (firmware) + 12.480s (loader) + 3.629s (kernel) + 40.887s (userspace) = 1min 6.097s 
    graphical.target reached after 40.795s in userspace
    systemd-analyze blame | head :

    Code:
    20.845s plymouth-quit-wait.service                                                               
     9.345s snapd.service                                                                            
     8.393s NetworkManager-wait-online.service                                                       
     7.241s dev-sda5.device                                                                          
     7.056s networkd-dispatcher.service                                                              
     5.979s udisks2.service                                                                          
     4.590s accounts-daemon.service                                                                  
     3.837s NetworkManager.service                                                                   
     3.372s polkit.service                                                                           
     3.328s plymouth-read-write.service
    please help
    Last edited by ahti-sc; September 9th, 2020 at 03:19 PM.

  2. #2
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,267
    Distro
    Xubuntu

    Re: Ubuntu 20 showing filesystem check hence taking too long to boot

    So, it boots in about 1 minute and 12 seconds? That does not sound outrageous to me at all. Please give us some specs on your equipment.

    Don't forget that Win10 "seems" to boot instantly: that is because Win10 does not shut down: it merely hibernates.

  3. #3
    Join Date
    Aug 2020
    Beans
    17

    Re: Ubuntu 20 showing filesystem check hence taking too long to boot

    I had ubuntu 18.04 before and that was faster and didn't had to do that filesystem check every time I boot up. One of the reasons I moved to Ubuntu 20 was because of fast boot up but I don't seem to get it

    core i5 6th gen
    8gb ddr 4
    1TB hdd

    During installation I divided Ubuntu into just two partitions root and home.
    Last edited by ahti-sc; September 9th, 2020 at 04:53 PM.

  4. #4
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Ubuntu 20 showing filesystem check hence taking too long to boot

    If there is a file system check at every boot of an installed system, something is wrong with the file system. Please fix it and check what might cause the damage.

    It is different with a live or persistent live system. In such systems you should add the boot option fsck.mode=skip in order to get rid of the checking.

  5. #5
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Ubuntu 20 showing filesystem check hence taking too long to boot

    Are you sure it is actually running a full filesystem check and not simply telling you the filesystem is clean which is what mine does.
    A fast check happens at each boot but it is almost instantaneous so will not be causing your slow(?) boot; but like Autodave I do not think that your boot time is slow but it would help to see the output of commands
    Code:
    inxi -Fzx
    sudo tune2fs -l /dev/sdx# | grep "Last checked:"
    where sdx# is the root partition of your system.
    The inxi command will show us your hardware and the tune2fs will show the last full filesystem check date.

  6. #6
    Join Date
    Aug 2020
    Beans
    17

    Re: Ubuntu 20 showing filesystem check hence taking too long to boot

    where to add fsck.mode=skip

  7. #7
    Join Date
    Aug 2020
    Beans
    17

    Re: Ubuntu 20 showing filesystem check hence taking too long to boot

    It shows the message without progress bar for 5-8 seconds. I don't see filesystem has been successfully completed or something like that it just boot up striaght. Will check the output of that command and give you reply with output.

  8. #8
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Ubuntu 20 showing filesystem check hence taking too long to boot

    Quote Originally Posted by ahti-sc View Post
    where to add fsck.mode=skip
    1. Please notice that this is relevant only for live and persistent live systems (not for installed systems).

    2. You can add it temporarily by editing at the grub or syslinux boot menu, and you can add it by editing a configuration file (for grub: the file grub.cfg).

    The following link can help you find how to add boot options, and fsck.mode=skip is a boot option,

    Boot options

  9. #9
    Join Date
    Feb 2014
    Beans
    202

    Re: Ubuntu 20 showing filesystem check hence taking too long to boot


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •