Results 1 to 5 of 5

Thread: Epson Stylus SX105 Printer not working after 20.04 install

  1. #1
    Join Date
    Feb 2014
    Beans
    202

    Epson Stylus SX105 Printer not working after 20.04 install

    The above printer worked in 16.04, but despite being detected and installed OK is unresponsive since fresh install of 20.04. It says printing completed, but nothing actually happens.

    Any help in getting it going would be much appreciated.

    Thanks

  2. #2
    Join Date
    Feb 2014
    Beans
    202

    Re: Epson Stylus SX105 Printer not working after 20.04 install

    Should have mentioned that I've tried installing printer-driver-escpr (which worked in 16.04) and also downgrading 20.04 installed printer-driver-escpr to the version present in 16.04.

  3. #3
    Join Date
    Feb 2014
    Beans
    202

    Re: Epson Stylus SX105 Printer not working after 20.04 install

    To finish the monologue (for the benefit of anyone else trying to keep one of these ancient printers going in 20.04) you need

    CUPS+Gutenprint v5.3.3 (color)

    Admin is best done from localhost in browser (couldn't get printer admin under settings to do it).

    It wasn't presented as an option until I installed printer-driver-gutenprint.

  4. #4
    Join Date
    May 2020
    Beans
    5

    Re: Epson Stylus SX105 Printer not working after 20.04 install

    Thank you so much you made my day . I was helping a friend and we ran just exactly into this problem!

  5. #5
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Epson Stylus SX105 Printer not working after 20.04 install

    Thread moved to Hardware.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •