Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Can't stop at grub menu

  1. #1
    Join Date
    Sep 2020
    Beans
    14

    Can't stop at grub menu

    Environment:

    On a Dell xps 15 9560 machine, Ubuntu 20.04.01 was just installed on the second drive on the machine. The first drive was already installed opensuse, which has been running well for a few years.

    The second drive on which ubuntu is installed was formatted and had nothing on it prior to installation. opensuse has nothing to do with it.

    The installation uses UEFI and secure boot enabled, since both opensuse and ubuntu support them.

    The installation finishes fine except that grub couldn't even show upon booting ubuntu, with three lines on the screen only:
    1. press f1 to retry booting
    2. press f2 to reboot to boot menu
    3. press f3 to reboot to setup

    I went to the Dell bios setup and manually added a boot entry which chooses the correct shim.efi file on the other drive (different from the original installation generated drive option), then ubuntu could boot fine.

    However my actual problem is:

    The boot only flashes the grub menu and does not stop.
    I have already tried holding/repeatedly pressing the following buttons:
    arrow key/space bar/shift/esc/e (maybe some other keys I find on the internet suggestions),
    but the grub menu (blue background with text) only flashes and can't be stopped.

    Since I could boot into ubuntu, I also checked the /etc/default/grub.cfg and noticed that GRUB_TIMEOUT_STYLE was set "hidden", so I changed it to "menu", according to
    https://www.gnu.org/software/grub/ma...-configuration

    I also changed the timeout to either "2" or "-1". (edit: and used the "update-grub" command)

    Nontheless, all these do not change anything. The grub menu only flashes and can't be stopped.
    Last edited by geckojames; September 2nd, 2020 at 11:56 AM. Reason: I updated and generated the new grub after making some changes

  2. #2
    Join Date
    Nov 2004
    Location
    Maine
    Beans
    2,395
    Distro
    Ubuntu

    Re: Can't stop at grub menu

    Change the grub time out to 5 or 10. That should slow it up enough to let you make choices.
    Of course don't forget to issue the sudo update-grub command after saving the changes.
    Wireless script
    Dave
    Registered Linux User #462608
    Morse Code an early Digital Mode.

  3. #3
    Join Date
    Sep 2020
    Beans
    14

    Re: Can't stop at grub menu

    Quote Originally Posted by kc1di View Post
    Change the grub time out to 5 or 10. That should slow it up enough to let you make choices.
    Of course don't forget to issue the sudo update-grub command after saving the changes.
    Quote Originally Posted by geckojames View Post
    Environment:

    Since I could boot into ubuntu, I also checked the /etc/default/grub.cfg and noticed that GRUB_TIMEOUT_STYLE was set "hidden", so I changed it to "menu", according to
    https://www.gnu.org/software/grub/ma...-configuration

    I also changed the timeout to either "2" or "-1". (edit: and used the "update-grub" command)

    Nontheless, all these do not change anything. The grub menu only flashes and can't be stopped.
    I don't think it's related to the grub options anymore, since making timeout value "-1", meaning waiting indefinitely didn't help. Besides interruption keys don't work in any case either.

  4. #4
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,787

    Re: Can't stop at grub menu

    In Ubuntu 20.04 default for /etc/default/grub contains:

    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=0
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    Change to:

    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=menu
    GRUB_TIMEOUT=3
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    Grub_Timeout should be > 0.
    In terminal, run sudo update-grub
    Reboot and Grub menu will appear.
    Last edited by Dennis N; September 3rd, 2020 at 03:46 AM.

  5. #5
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Can't stop at grub menu

    Lets see details, use ppa version with your live installer (2nd option) or any working install, not older Boot-Repair ISO:
    Please copy & paste the pastebin link to the Boot-info summary report ( do not post report), do not run the auto fix till reviewed.
    https://help.ubuntu.com/community/Boot-Repair &
    https://sourceforge.net/p/boot-repair/home/Home/
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #6
    Join Date
    Sep 2020
    Beans
    14

    Re: Can't stop at grub menu

    Quote Originally Posted by Dennis N View Post
    In Ubuntu 20.04 default for /etc/default/grub contains:

    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=0
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    Change to:

    Code:
    GRUB_DEFAULT=0
    GRUB_TIMEOUT_STYLE=menu
    GRUB_TIMEOUT=3
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    Grub_Timeout should be > 0.
    In terminal, run sudo update-grub
    Reboot and Grub menu will appear.
    Thank you. Surprisingly it works.
    However I notice that pressing "down arrow" or "spacebar" actually skips the grub menu. But if you wait a second on the grub menu screen "down arrow" works as a selection key.
    Any suggestion on which key is safe to press to safely stop grub timeout counting?
    Last edited by geckojames; September 3rd, 2020 at 08:26 AM. Reason: adding quote

  7. #7
    tea for one is offline Grande Half-n-Half Cinnamon Ubuntu
    Join Date
    May 2008
    Beans
    929
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Can't stop at grub menu

    Quote Originally Posted by geckojames View Post
    Any suggestion on which key is safe to press to safely stop grub timeout counting?
    Once the grub menu is displayed, down arrow will also stop the timer, then you can choose your selection with both up and down arrows.

    (I think space bar and up arrow will also pause the timeout)

    I find a 10 second Timeout is more comfortable.

  8. #8
    Join Date
    Sep 2020
    Beans
    14

    Re: Can't stop at grub menu

    I seem to understand better the issue:

    update-grub only works for one grub but I have two working grub for this ubuntu installation:
    One is under FS0:\EFI\boot\bootx64.efi, the other is under FS1:\EFI\ubuntu\shimx64.efi.

    update-grub only updates the latter but not the former. If I boot into the former ubuntu, the grub menu is not stoppable (I presume it still uses GRUB_TIMEOUT_STYLE=hidden)
    I wonder which /etc/default/grub controls the former grub, and which efi should I choose to be the default boot entry, which can be configured in the BIOS setup.

    edit2: exchange former<->latter
    Last edited by geckojames; September 3rd, 2020 at 02:42 PM. Reason: adding FS0/FS1

  9. #9
    Join Date
    Sep 2020
    Beans
    14

    Re: Can't stop at grub menu

    I actually have no idea which efi is configured by /etc/default/grub now, since I find that either of them can have the unstoppable grub menu issue.

    Under FS0:EFI, I have the following directories: Dell, boot, opensuse. (under boot it has bootx64.efi and fallback.efi.)
    Under FS1:EFI, I have the following directories: ubuntu, (under which there are grubx64.efi, shimx64.efi, mmx64.efi, BOOTX64.CSV, grub.cfg)
    BOOT (under which there are BOOTX64.EFI, fbx64.efi, mmx64.efi)
    I know that ubuntu is installed on the second drive. Now which efi should I choose and stick to so that the grub menu would listen to the /etc/default/grub change???

  10. #10
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Can't stop at grub menu

    I think one grub is OpenSuse and other is Ubuntu. But do not know if OpenSuse uses grub.

    The bootx64.efi is often called the fallback and is just a copy of shimx64.efi (or Windows .efi file). It looks like OpenSuse creates a fallback.efi also.

    If you post the link to a report from Boot-Repair you can see all the details.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •