Results 1 to 3 of 3

Thread: fsck: dirty bit is set

  1. #1
    Join Date
    Sep 2020
    Beans
    2

    fsck: dirty bit is set

    This issue began when I force shutdown my system during an update. After that, I could only boot by changing the boot parameter in grub from "ro" to "rw".
    Then, when I run fsck, I get the attached output every time I boot. I've pasted it here also:

    `0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.`

    What can I do to repair my filesystem?



    As a sidenote, another thing that happens is that after adding a swap file, htop shows `OK/16.0G` swap usage, which **may** be another manifestation of this filesystem problem.
    Attached Images Attached Images

  2. #2
    Join Date
    Jun 2018
    Beans
    49

    Re: fsck: dirty bit is set

    boot from a CD and run fsck -a /dev/sda1


  3. #3
    Join Date
    Sep 2020
    Beans
    2

    Re: fsck: dirty bit is set

    Can I do this by booting in the advanced options -> linux (recovery mode) option in GRUB and dropping to shell? Also, I assume I can replace /dev/sda1 with the volume my main filesystem is mounted on?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •