Results 1 to 6 of 6

Thread: 3400g screen artifacts

  1. #1
    Join Date
    Sep 2020
    Beans
    3

    3400g screen artifacts

    Hey guys long time lubuntu user (since 2010) but new to the forum here.
    I recently got a new Ryzen 5 3400g box (i love it) and on lubuntu, as well as manjaro, I get severe graphics artifacts. heres an example from yesterday :
    https://ibb.co/t82bwsx

    This happens within all apps and environments.

    Seems to me like this might be a video driver issue? I have no problems in Windows 10, only linux, so I suspect the driver, but I dont know for sure.
    If anyone has any advice, I would certainly love to hear it!

    Thanks

    gooch
    Last edited by goochmcroach; September 1st, 2020 at 10:41 AM. Reason: additional info

  2. #2
    Join Date
    Sep 2020
    Beans
    3

    Re: 3400g screen artifacts

    heres a fresh one
    https://ibb.co/sVVbdmX
    i use my phone camera because if I press prtscr the screen refreshes and the artifacts are not captured.

  3. #3
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: 3400g screen artifacts

    Quote Originally Posted by goochmcroach View Post
    Seems to me like this might be a video driver issue? I have no problems in Windows 10, only linux, so I suspect the driver, but I dont know for sure.
    If anyone has any advice, I would certainly love to hear it!
    My advice would be to post details of your graphics hardware so that people can give relevant advice.

    Also, if you want to include images in your posts, please use the attachment facility to upload them to the forum server, rather than links to off-site hosting sites which many are chary of clicking. Go to the advanced message editor and use the paperclip icon to upload pictures.

    Welcome to the forum!
    Ubuntu 18.04 Desktop Guide - Ubuntu 20.04 Desktop Guide - Forum Guide to BBCode - Using BBCode code tags - IRC #ubuntuforums

    Member: Not Canonical Team

    If you need help with your forum account, such as SSO login issues, username changes, etc, the correct place to contact an admin is here. Please do not PM me about these matters unless you have been asked to - unsolicited PMs concerning forum accounts will be ignored.

  4. #4
    Join Date
    Jun 2018
    Beans
    81

    Re: 3400g screen artifacts

    If you have wayland enabled (I think it's default on Lubuntu these days), try to disable it.

  5. #5
    Join Date
    Sep 2020
    Beans
    3

    Re: 3400g screen artifacts

    Hey guys, thanks for responding. After digging around in ubuntuforums, I found my issue and seems as if I resolved it. I disabled IOMMU in BIOS and so far, no glitching! I will certainly notify if the artifacts return!
    Coffeecat : apologies for breach of protocol. Noted. Thanks to you, too dinkidonk. I should have looked here for the solution weeks ago. Thanks!

  6. #6
    Join Date
    Nov 2009
    Beans
    Hidden!
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: 3400g screen artifacts

    could you give new kernel a try and then report to launchpad bug? supposedly the issue is resolved in newer kernel, however it makes me wonder since you said same thing happens on Manjaro.
    Read the easy to understand, lots of pics Ubuntu manual.
    Do i need antivirus/firewall in linux?
    Full disk backup (newer kernel -> suitable for newer PC): Clonezilla
    User friendly full disk backup: Rescuezilla

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •