Results 1 to 9 of 9

Thread: wireless connection sometimes stopped working with new ISP

  1. #1
    Join Date
    Aug 2013
    Beans
    4,369

    wireless connection sometimes stopped working with new ISP

    Hi,

    I am sharing internet with my neighbours via wifi, since about two weeks ago they changed the internet provider and I am experiencing some sporadic disconnection. The wifi is still connected according to network manager but I can't go to any website (on Firefox it says site not found) The quick fix would be to disconnect (from network manager) and then reconnect and it works again. It doesn't happen very often but it is still annoying.

    It never happened before with the previous provider. Also it only happens on this laptop (ubuntu 20.04), I have another two: one with Ubuntu 16.04 and another with Kubuntu 20.04 and this doesn't happen.

    Here is the output from the wireless-info scripts.

    Thanks.

  2. #2
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,891
    Distro
    Ubuntu Mate 20.04 Focal Fossa

    Re: wireless connection sometimes stopped working with new ISP

    Lets try
    Code:
    sudo iwconfig wlp2s0 power off
    sudo sed -i "s/wifi.powersave = 3/wifi.powersave = 2/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
    sudo systemctl restart network-manager.service
    Also try channel 1 instead of 6

  3. #3
    Join Date
    Aug 2013
    Beans
    4,369

    Re: wireless connection sometimes stopped working with new ISP

    Hi, thanks.

    But the laptop is plugged into an AC outlet so I don't think power management is the issue.
    Last edited by monkeybrain20122; August 31st, 2020 at 10:48 PM.

  4. #4
    Join Date
    Aug 2013
    Beans
    4,369

    Re: wireless connection sometimes stopped working with new ISP

    These are the error message when it stops from dmesg | tail
    Code:
    [60181.243168] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60181.345650] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60181.448153] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60181.550809] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60181.653061] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60181.755415] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60181.858098] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60181.959729] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60182.062665] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring
    [60182.165011] wlp2s0: cannot understand ECSA IE operating class, 11, ignoring

  5. #5
    Join Date
    Aug 2013
    Beans
    4,369

    Re: wireless connection sometimes stopped working with new ISP

    bump

  6. #6
    Join Date
    Aug 2013
    Beans
    4,369

    Re: wireless connection sometimes stopped working with new ISP

    I disabled ipv6 and apparently it works, for one week I haven't lost connection. Is there any side effect to that?

  7. #7
    Join Date
    Feb 2010
    Location
    Obscurial Springs
    Beans
    14,558
    Distro
    Ubuntu Budgie Development Release

    Re: wireless connection sometimes stopped working with new ISP

    I've not seen any problems from disabling ipv6 and doing so solved the same problem for me.
    “Start where you are. Use what you have. Do what you can".

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Flavors

  8. #8
    Join Date
    Aug 2013
    Beans
    4,369

    Re: wireless connection sometimes stopped working with new ISP

    Too soon, it just happens again.

  9. #9
    Join Date
    Aug 2013
    Beans
    4,369

    Re: wireless connection sometimes stopped working with new ISP

    These disconnections happen sporadically, sometimes it work for days with no issues, sometimes it disconnects (but networkmanager always shows connected) several times a day and disable and then enable wifi always works.

    so far I have disabled ipv6, set power save to 2 and tried the solution of post #5 here, still disconnecting from time to time. This never happened until they changed the ISP.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •