Results 1 to 10 of 10

Thread: fspot broke my mime type (a howto)

  1. #1
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    fspot broke my mime type (a howto)

    I'm not exactly sure of the how or the why or what external circumstances contirbuted to this, but on the two seperate occasions that I have installed fspot on a clean dapper install, it hosed my image mime types. Thumbnails wouldn't be displayed in nautilus unless I selected the image; when viewing an image with eog, I couldn't use the arrows to browse through the other images in the same directory; trying to just double-click on an image gave me a warning:
    Code:
    The filename "control_panel.jpg" indicates that this file is of type "jpg document". The contents of the file indicate that the file is of type "JPEG image". If you open this file, the file might present a security risk to your system.
    
    Do not open the file unless you created the file yourself, or received the file from a trusted source. To open the file, rename the file to the correct extension for "JPEG image", then open the file normally. Alternatively, use the Open With menu to choose a specific application for the file.
    The first time this happened with png images, this time with jpg images. If I renamed the suffix (for example jpeg, or PNG) it would work just fine. It's rather irritating when you have to rename gigabytes of images. So I managed track down the culprit (again) and hve decided to put this on the forum for when I forget again.. I mean share this with the world. Your results may vary.

    *Open nautilus and select "Show hidden files" from the view menu.
    *In your home folder, look for ".local"-- it should be a folder-- and open it.
    *Find the folder named "share" and open it.
    *Find the folder named "mime" and open it.
    *Find the file named "globs" and open it.

    If the file looks something like this:
    Code:
    # This file was automatically generated by the
    # update-mime-database command. DO NOT EDIT!
    application/x-extension-jpg:*.jpg
    we have the perpetrator of this vile inconvience.
    *Add "# " in front of the line "application/x-extension..." REMEMBER THE SPACE, it's probably crucial. Now save the file and test your reslults.

  2. #2
    Join Date
    Jun 2005
    Beans
    20

    Re: fspot broke my mime type (a howto)

    YOU LEGEND!!!
    Worked like a dream!

  3. #3
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: fspot broke my mime type (a howto)

    Haha. Yeah, it was a pain to find it the first time. Glad it was of help to you.

  4. #4
    Join Date
    Feb 2007
    Beans
    1

    Re: fspot broke my mime type (a howto)

    Thanks pyros, real life saver This should be fixed though as I'm sure a lot of other people have the same problem, as this was a default setting for me anyways...

  5. #5
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: fspot broke my mime type (a howto)

    Quote Originally Posted by battlesquid View Post
    Thanks pyros, real life saver This should be fixed though as I'm sure a lot of other people have the same problem, as this was a default setting for me anyways...
    I have to wonder as to the hows and whys on this problem. It certainly is strange. Glad I wasn't the only one who had this problem.

  6. #6
    Join Date
    Nov 2006
    Beans
    4

    Re: fspot broke my mime type (a howto)

    There's now a bug open on this at https://launchpad.net/ubuntu/+source/f-spot/+bug/91128

    Let us know over there if you have any more ideas what might be causing this.

  7. #7
    Join Date
    Mar 2007
    Beans
    37
    Distro
    Ubuntu 6.10 Edgy

    Smile Re: fspot broke my mime type (a howto)

    Thank you so very much. It was just what I needed.

  8. #8
    Join Date
    Nov 2007
    Beans
    2

    Re: fspot broke my mime type (a howto)

    This should be a sticky thread! I've been looking for a solution for this problem for two days now,


    Thanks.

  9. #9
    Join Date
    Sep 2007
    Beans
    4

    Re: fspot broke my mime type (a howto)

    That realy worked glad you posted this man.

  10. #10
    Join Date
    Sep 2007
    Beans
    4

    Re: fspot broke my mime type (a howto)

    That really worked glad you posted this man. I was having a pain right clicking on my jpeg's and choosing my image viewer every time.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •