Results 1 to 7 of 7

Thread: Urgent: black screen upon boot after restarts, probable firmware issue

  1. #1
    Join Date
    Aug 2020
    Beans
    17

    Urgent: black screen upon boot after restarts, probable firmware issue

    I have a very strange problem. I've had some bugs with the default gnome version of ubuntu and yesterday it broke completely, unable to boot. Nothing was actually lost though because of internet and external storage. Reinstalling it from USB worked at first but upon trying to update some software when prompted to, the restart would leave my screen black it wouldn't boot by any method. So I decided to install kubuntu finally, and had the exact same problem despite that they occupied separate install disks and each time the installs would format and replace all content on the SSD. This seems like a firmware problem since it happens irrespective of the SSD's contents, but I'm not sure. Ever since I tried ubuntu first I had a somewhat similar situation. Powering on or restarting would lead to an infinite ASUS logo screen, but I always got into ubuntu easily through the UEFI menu by holding ESC immediately, so it wasn't a real issue. That's been a thing since my 1st day of linux. But the new problem is a far worse version of that one where instead, I can't load any part of the OS by any method on regular gnome ubuntu, and on KDE. At least the UEFI still works tho.
    Computer type: ASUS zenbook Q536FD
    https://www.asus.com/us/Laptops/Q536FD/specifications/
    Last edited by lelmst; August 12th, 2020 at 06:56 PM.

  2. #2
    Join Date
    Aug 2020
    Beans
    17

    Re: Urgent: black screen upon boot after restarts, probable firmware issue

    Flashing the BIOS completely fixed everything and kubuntu works fine. Now I must know why ubuntu decided to modify the BIOS completely unprompted resulting in gnome partially breaking during the session before the first broken reboot

  3. #3
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    20,968
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Urgent: black screen upon boot after restarts, probable firmware issue

    How can we help without knowing the OS version? Did you read the "Release Notes" for that version which probably has instructions to get around a black screen issue?

    Have you patched the firmware from Asus?

    For example, 20.04 have known problems with nVidia GPUs.

  4. #4
    Join Date
    Aug 2020
    Beans
    17

    Re: Urgent: black screen upon boot after restarts, probable firmware issue

    Kubuntu works after flashing the BIOS and I have absolutely none of the old issues.
    Idea 2:
    It was actually probably messed up from day 1 and that's why I had the first boot and failed second login issues. No idea if a modification of BIOS happened again yesterday or it just got worse for other reasons.

  5. #5
    Join Date
    Aug 2020
    Beans
    17

    Re: Urgent: black screen upon boot after restarts, probable firmware issue

    I was going to go read it actually but the BIOS flashing removed every boot and login issue I've had so this has been solved. Thanks for advice

  6. #6
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    20,968
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Urgent: black screen upon boot after restarts, probable firmware issue

    If fixed, please help the community, Thread tools ---> SOLVED so others know easily.
    Please.

  7. #7
    Join Date
    Aug 2020
    Beans
    17

    Re: Urgent: black screen upon boot after restarts, probable firmware issue

    Alright I'll do that
    There's a lot of edits in the post btw but it's mostly to add new info or better clarify things

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •