Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Grub shows gray screen when system in LUKS.

  1. #11
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    21,377
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Grub shows gray screen when system in LUKS.

    Posted for lurkers, since the OP has rejected using LVM.

    I'm running EFI + LUKS + LVM just fine. A working encrypted storage layout:
    https://ubuntuforums.org/showthread....7#post13883277

    The layout in that link was started with a default install, the "root" LV was lvreduced, then other LVs were added as desired lvcreate and mounted using the sudoedit /etc/fstab. The 16.04 installer always allocated the root LV to the entire disk. With 20.04, the installer seems to use 200GB for the only LV created, if there is extra storage, or in the "do something else" setup, we can manually size the PV, VG, and LVs.

    Oldfred has a few posts here on getting Ubuntu UEFI installed on multiple disks. Seems the BIOS settings only want 1 /boot/efi/ directory on any connected disks, so tricking it is required. If any OS on the system uses UEFI for boot, then all of them should to avoid BIOS resetting stuff. Was in the BIOS for one of my systems and saw settings that provided these boot options:
    • UEFI-only
    • BIOS-only
    • UEFI-preferred, Legacy BIOS fallback
    • Legacy BIOS-preferred, UEFI fallback

    On that system, I'm using Legacy BIOS boot only. It has been migrated forward since around 2012 when UEFI boot was new and had lots of unsolved problems on Linux.

  2. #12
    Join Date
    Aug 2020
    Beans
    7

    Re: Grub shows gray screen when system in LUKS.

    TheFu, I have encountered a serious problem with Grub. The only solution seems to be to install Ubuntu on a SATA SSD, which would be a terrible solution because my computer is for organizing my files and sometimes I run scripts on thousands of files which could take half an hour.

    As you can read in #7 and #10, I started to use the "whole disk" from the installer with LVM.
    I have done many more tests, with all the EFI and Grub/boot partitions removed from all SSDs, so nothing gets in the way.

    My conclusion:
    Grub is not up to date. It does not work on my computer (AMD Ryzen 5 3600 + Gigabyte B550M Aorus Pro) when installing Ubuntu on a PCIe SDD (either NVMe or SATA mode).
    The EFI and LUKS and LVM are not part of the problem, since a "whole disk" install without LUKS does not show the Grub menu either. I tried that a few times.

    Everything works fine with a SATA SSD.

    Manjaro linux does show the Grub/boot menu when installed on a PCIe SSD (SATA mode) without LUKS.
    Sadly, a Ubuntu partition with LUKS on the other PCIe SDD is not recogned and can not be started.
    When I try Manjaro linux with LUKS, then Grub is inside the LUKS partition (that's a bad choice) and the password is requested before Grubs starts. However, when I type the password, then nothing happens.
    Last edited by jhnur; August 13th, 2020 at 12:42 PM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •