Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: How do I disable F10 on ubuntu 20.04

  1. #1
    Join Date
    Jan 2010
    Beans
    9

    How do I disable F10 on ubuntu 20.04

    Hi,

    Maybe this is a gnome question but hopefully, someone can answer here as my google-fu is failing me. I found a couple of answers on how to disable F10 but it appears to only work on older versions of ubuntu/gnome. None of them worked for me. I've tried finding a binding for F10 under "keyboard shortcuts" in settings, but nothing. Does anyone know how I go about fixing this?

  2. #2
    Join Date
    May 2013
    Location
    Galiza
    Beans
    2,364
    Distro
    Ubuntu

    Re: How do I disable F10 on ubuntu 20.04

    On my Ubuntu 20.04, the F10 key does nothing.

    Why do you think it needs to be disabled? What does the F10 key do in your system that you don't want?

  3. #3
    Join Date
    Jan 2010
    Beans
    9

    Re: How do I disable F10 on ubuntu 20.04

    In my case, my left mouse button acts if am holding my left button down continuously. You know, like you do when select text. Except it never stops here. So basically my mouse stops working and I need to reset.

    edit: Correction, pulling the usb cable out worked too.

    edit2: Never mind, it worked once. But I can't replicate the fix.
    Last edited by frostfield; August 4th, 2020 at 02:06 PM.

  4. #4
    Join Date
    May 2013
    Location
    Galiza
    Beans
    2,364
    Distro
    Ubuntu

    Re: How do I disable F10 on ubuntu 20.04

    So, what exactly a mouse has to do with F10?

  5. #5
    Join Date
    Oct 2005
    Location
    Al Ain
    Beans
    10,031

    Re: How do I disable F10 on ubuntu 20.04

    To answer your question:
    Assuming that you are using Xorg.
    Use xev to see the key bindings and xmodmap to change them.

  6. #6
    Join Date
    Jan 2010
    Beans
    9

    Re: How do I disable F10 on ubuntu 20.04

    Quote Originally Posted by CelticWarrior View Post
    So, what exactly a mouse has to do with F10?
    I mean, my left mouse button starts acting the way I described when I press F10.

  7. #7
    Join Date
    Jan 2010
    Beans
    9

    Re: How do I disable F10 on ubuntu 20.04

    Quote Originally Posted by HermanAB View Post
    To answer your question:
    Assuming that you are using Xorg.
    Use xev to see the key bindings and xmodmap to change them.
    I'm sure it would help, but the terminal starts spamming messages when I click F10.

  8. #8
    Join Date
    May 2013
    Location
    Galiza
    Beans
    2,364
    Distro
    Ubuntu

    Re: How do I disable F10 on ubuntu 20.04

    So, now the question is WHY are you pressing F10? And is it really F10? Many laptops now have additional functions added to the Fn keys that are specific for vendor/model -and-, very important the fad now is to have that additional functions defined by the manufacturer as the default (meaning: when users press any of the F keys it's the additional function rather than the typical one that is triggered so, in order to use the actual F key function - in the desktop (system-wide) or in a program (software specific) - users actually have to press FN+F...; it used to be the other way around, of course). This feature may or may not be switched off in UEFI ("BIOS").

    In a nutshell, whatever "problem" you're supposedly having is very likely related with your specific hardware and not at all related with the OS and system-wide keyboard shortcuts. But again, DON'T PRESS the key and "problem" solved! So simple. Unlike what you want to do that seems, at best, silly.
    Last edited by coffeecat; August 4th, 2020 at 02:44 PM. Reason: <ahem>

  9. #9
    Join Date
    Jan 2010
    Beans
    9

    Re: How do I disable F10 on ubuntu 20.04

    I realize I could have been a bit more clear, but "don't press the F10" is not helping one bit. Completely unnecessary comment.

    Firstly I'm using a mechanical USB keyboard. So the issue might be there, thank you. It worked fine with Fedora though.

    Secondly, my IDE is set up to "Step over" a line of code with the F10 button, but ubuntu/gnome/whatever hijacks this and messes things up. Sure, I could rebind the F10 to something else, but I tried asking here first not expecting any condescending responses.
    Last edited by ajgreeny; August 4th, 2020 at 09:51 PM. Reason: wording

  10. #10
    Join Date
    Jan 2010
    Beans
    9

    Re: How do I disable F10 on ubuntu 20.04

    It was my keyboard, F9 and F10 have some macro features which I never use. I had to install razor drivers for the keys to work properly.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •