Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Running newer version of VirtualBox

  1. #1
    Join Date
    Dec 2010
    Beans
    342

    Running newer version of VirtualBox

    I installed virtualbox from the ubuntu repo, had some issues with it, so I uninstalled it (sudo apt purge), then downloaded the .deb 6.1 file from VirtualBox's website, and installed. I now get this error when I attempt to run a VM:
    Code:
    RTR3InitEx failed with rc=-1912 (rc=-1912)
    The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing
    
    '/sbin/vboxconfig'
    
    may correct this. Make sure that you are not mixing builds of VirtualBox from different sources.
    
    
    where: supR3HardenedMainInitRuntime what: 4 VERR_VM_DRIVER_VERSION_MISMATCH (-1912) - The installed support driver doesn't match the version of the user. 
    I did what it says, but I get the same error.

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,234
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Running newer version of VirtualBox

    Follow the instructions at https://www.virtualbox.org/wiki/Linu...xdistributions to add the Oracle VB repository to your system. Then system updates will automatically update VirtualBox when there is a new version available.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  3. #3
    Join Date
    Dec 2010
    Beans
    342

    Re: Running newer version of VirtualBox

    I still get the same error after following those instructions.

  4. #4
    Join Date
    Jun 2016
    Beans
    2,047
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Running newer version of VirtualBox

    Quote Originally Posted by sniper8752 View Post
    I installed virtualbox from the ubuntu repo, had some issues with it, so I uninstalled it (sudo apt purge)
    Could you please post the entries from /var/log/apt/history.log for both the installation and uninstallation of the repo package?

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,234
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Running newer version of VirtualBox

    The version in the Oracle repository is designed to compile the required "kernel module" when it is installed.

    Did you use "sudo apt install virtualbox-6.1"? That's the version in the Oracle repository. The package named simply "virtualbox" is the one in the Ubuntu repositories. It should be automatically uninstalled during the process that installs the virtualbox-6.1 package.

    Just to be sure, run

    Code:
    sudo apt-get purge virtualbox
    then run

    Code:
    sudo apt update
    sudo apt install virtualbox-6.1
    Last edited by SeijiSensei; August 2nd, 2020 at 09:56 PM.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    Join Date
    Dec 2010
    Beans
    342

    Re: Running newer version of VirtualBox

    Quote Originally Posted by SeijiSensei View Post
    The version in the Oracle repository is designed to compile the required "kernel module" when it is installed.

    Did you use "sudo apt install virtualbox-6.1"? That's the version in the Oracle repository. The package named simply "virtualbox" is the one in the Ubuntu repositories. It should be automatically uninstalled during the process that installs the virtualbox-6.1 package.

    Just to be sure, run

    Code:
    sudo apt-get purge virtualbox
    then run

    Code:
    sudo apt update
    sudo apt install virtualbox-6.1
    Did all of this, and it said it is already the newest version.

  7. #7
    Join Date
    Aug 2013
    Beans
    4,365

    Re: Running newer version of VirtualBox

    Did you download and install the guest additions?

  8. #8
    Join Date
    Dec 2010
    Beans
    342

    Re: Running newer version of VirtualBox

    Quote Originally Posted by monkeybrain20122 View Post
    Did you download and install the guest additions?
    Yes.

  9. #9
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,234
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Running newer version of VirtualBox

    Quote Originally Posted by sniper8752 View Post
    Did all of this, and it said it is already the newest version.
    So did you run /sbin/vboxconfig as the error message read? This compiles and installs the required kernel module. You need to run it with sudo, i.e., "sudo /sbin/vboxconfig". You shouldn't need to do this when installing from the Oracle repository, but your experience is so far removed from mine that it's worth giving it a try.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  10. #10
    Join Date
    Aug 2013
    Beans
    4,365

    Re: Running newer version of VirtualBox

    Maybe a long shot, I ran into something like that before, it turned out I have switched to a different version of gcc and forgot to switch back

    so are you playing with an alternative version of gcc?

    Code:
    gcc --version

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •