Results 1 to 4 of 4

Thread: My Conky doesn't honour use_xft = true until I open and save it

  1. #1
    Join Date
    Apr 2020
    Location
    where the work takes me
    Beans
    181
    Distro
    Ubuntu 18.04 Bionic Beaver

    My Conky doesn't honour use_xft = true until I open and save it

    Hi everyone,

    basically when I boot my computer, 99% of the time my Conky doesn't respect 'use_xft = true' and remains a small square in the corner of my desktop until I open my .conkyrc and save it again. All other configurations are applied. On an extremely rare occasion it will behave but I mean like extremely rare.

    Any thoughts?

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    7,925
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: My Conky doesn't honour use_xft = true until I open and save it

    I've not seen that, but there have been things in the past where conky gets in a pickle because it's starting before the window manager has finished setting things up. The suggestion then is to stick a sleep for a few seconds in front of the command that launches conky.

  3. #3
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,536
    Distro
    Ubuntu

    Re: My Conky doesn't honour use_xft = true until I open and save it

    Conky has built in pause option
    Run something like
    Code:
    conky -p 20
    Will delay from launching for 20 seconds.
    If running conky with other option then just tack the -p at the end.
    something like
    Code:
    conky -c /this/that/theotherthing/conkyrc -p 20
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  4. #4
    Join Date
    Apr 2020
    Location
    where the work takes me
    Beans
    181
    Distro
    Ubuntu 18.04 Bionic Beaver

    Smile Re: My Conky doesn't honour use_xft = true until I open and save it

    Quote Originally Posted by deadflowr View Post
    Conky has built in pause option
    Run something like
    Code:
    conky -p 20
    Will delay from launching for 20 seconds.
    If running conky with other option then just tack the -p at the end.
    something like
    Code:
    conky -c /this/that/theotherthing/conkyrc -p 20
    Quote Originally Posted by CatKiller View Post
    I've not seen that, but there have been things in the past where conky gets in a pickle because it's starting before the window manager has finished setting things up. The suggestion then is to stick a sleep for a few seconds in front of the command that launches conky.
    Thanks to you both, I went with a simple...
    Code:
    /usr/bin/conky -p 2
    ...which sorted it nicely, just because it's a Conky option.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •