Page 5 of 5 FirstFirst ... 345
Results 41 to 43 of 43

Thread: Ubuntu 18.04: Trouble fixing bad install of Okular

  1. #41
    Join Date
    Jul 2019
    Location
    Melb, Aus
    Beans
    54
    Distro
    Ubuntu

    Re: Ubuntu 18.04: Trouble fixing bad install of Okular

    Quote Originally Posted by Dennis N View Post
    Using (Gnome) Software, there was no feedback as to progress. ... Now, I would rather install from the terminal, since it does show what is happening.
    With 20/20 hindsight that is what I would certainly do. When feeling my way around in a new environment it was a case of traps for young players.

    Searched for problems with Snap tonight. Along the way learnt that Canonical is pushing it hard, intends to rely on it to distribute frequently updated packages. Didn't realise Snaps are silently updated in the background without user's awareness, request or permission. Devs like this because all users have the most up to date package. Also security benefits. Some object because it seems a little underhanded. For Ubuntu the upshot is that Snap is to be an essential software distribution format and channel.

    The searches pulled up a slightly different set of commands to remove snapd. I wound back the system with the image made two days ago and gave them a try.
    Code:
    sudo snap remove --purge <package1> <package2> <packageN>
    sudo rm -rf /var/cache/snapd/
    sudo apt autoremove --purge snapd gnome-software-plugin-snap
    rm -fr ~/snap
    No joy. Reinstalled snapd. Tested by installing Snaps that had given me problems before; they still didn't work.

    You can supply the icon for a snap. The atari800-jz snap didn't provide an icon. I copied the snap's .desktop file to ~/.local/share/applications and included an Icon= line. That worked. This also gives us a way to change the displayed name.
    But for p7zip-desktop I would have to retrieve it somehow from a system image file.
    Otherwise those are handy tricks to have up my sleeve.

  2. #42
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,753

    Re: Ubuntu 18.04: Trouble fixing bad install of Okular

    Didn't realise Snaps are silently updated in the background without user's awareness, request or permission.
    Flatpak is doing this too. But not before Ubuntu 20.04. You get a notification about it (see attached). I'm not aware of any settings for the updating policy in either Snaps or Flatpak. But, I don't really mind the automatic updating, and Ubuntu itself does automatic security updates in the background.
    Attached Images Attached Images
    Last edited by Dennis N; August 7th, 2020 at 01:55 PM.

  3. #43
    Join Date
    Jul 2019
    Location
    Melb, Aus
    Beans
    54
    Distro
    Ubuntu

    Re: Ubuntu 18.04: Trouble fixing bad install of Okular

    Through this thread I've come to realise Snap is an essential element of the contemporary Ubuntu experience, an experience partially denied to me. Having tried every means available to me to repair the system over the last 2w left me with few alternatives. I exercised my prerogative as sole authority of my computer to summon the football and whip out my biscuit. It was time for the nuclear option.

    Scary, but not bone chilling like this:
    nuclear-football-b.jpg

    I made a fresh and clean install of Ubuntu 18.04 LTS.

    Etcher
    Used it to flash ISO image to USB stick. There must be a lot happening behind its minimalist GUI. It made the job easy, no decisions to be made. Select ISO file, select target drive, done. Installed it to old system. Clicking on its *.AppImage file did not create a *.desktop launcher as far as I could tell. Ditto on new system. Made DIY launcher instead.

    Ubuntu OS install experience
    Was gobsmacked at how dazzlingly fast it was. It helps that boot drive is NVMe. USB stick was ~10yo USB 3.0. Installation itself completed in about a minute, possibly less. Preparatory work took much longer: image entire boot drive; read Ubuntu installation notes of my commercial partition & boot manager; carefully select "Something Else" parameters in Ubuntu installer. Hit the go button and whammo. First time around Ubuntu had been installed from DVD media. Won't bother doing that again.

    Ubuntu 18.04.5 LTS installed
    Old system was 18.04.4 LTS. It was updated regularly. No idea why it was behind current point release.
    Also downloaded ISO for 20.04.1 LTS. Have enough room on NVMe drive to try it too. Might do after I have finished slog of installing software and changing prefs for new 18.04.5.

    Snap test
    Installed Okular Snap via terminal. The pause before its first launch was an apprehensive few moments. Success. What a relief.

    p7zip-desktop Snap icon
    Copied its *.desktop file from /var/lib/snapd/desktop/applications to ~/.local/share/applications. Then had had to remind myself how to change file permissions and owner before I could do the rest. Had read all the relevant info months ago in The Linux Command Line by William Schotts. When it came to the crunch none of the salient info would come to me. Better return to TLCL for more reading and learning.
    Got there though. Happy that p7zip-desktop Snap now has working DIY icon and custom launcher name.
    Modified Okular Snap launcher too. Changed Name= line to distinguish it from Okular Flatpak. Changed file name of surplus generic Okular Snap launcher to hide icon.

    Problematic pdf file bug report

    Today received update from bugs.kde.org.
    It was a bug in Poppler, a pdf rendering library. One of its devs fielded the bug report.
    https://bugs.kde.org/show_bug.cgi?id=424779
    Said it will be fixed in Poppler 20.09.
    Don't know when version with that bug fixed will make it to Linux repos. After updating new system Poppler version was 0.62.0. I was able to update it via PPA to 0.74.0. Tagged release points are up to 0.90.1 and 20.08. Those could take awhile to filter down.
    https://gitlab.freedesktop.org/poppler/poppler/-/tags
    Last edited by nought2; August 10th, 2020 at 05:36 AM.

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •