Results 1 to 3 of 3

Thread: Can't access items in the (GNU GRUB 2.04) UEFI Firmware Settings (Ubuntu 20.04)

  1. #1
    Join Date
    Jul 2020

    Can't access items in the (GNU GRUB 2.04) UEFI Firmware Settings (Ubuntu 20.04)

    Trying to re-enable my front camera on my Surface Pro 3 running Ubuntu 20.04 (GNU GRUB v2.04) but am unable to select the option. The GRUB menu opens, I select UEFI Firmware Settings, I am prompted for a password (I've never set one). I can get past the password by hitting enter while it's blank, but I am unable to select certain options, specifically "Secure Boot Control", "Administrator Password", or any of the menu items within "Advanced Device Security"

    Images here:

    I have tried passwords "root" and "password", and I cannot enter my root user password because only lowercase letters are allowed in the password screen (see image above).

    Any ideas how I can edit those menu entries? My front camera is disabled and I would like to be able to use it for web-meetings.

    Some extra information that might be important: Ubuntu20.04 and Windows 10 are both loaded. I suspect there is some kind of default password that I would need to enter to have access, but my Google-Fu is not strong enough to find it if that is the case.

  2. #2
    Join Date
    Jun 2009
    SW Forida

    Re: Can't access items in the (GNU GRUB 2.04) UEFI Firmware Settings (Ubuntu 20.04)

    The grub menu item should just take you into UEFI, just like using Windows or using direct keys.
    This is not a grub issue & you should change title to refer to a Surface Pro UEFI issue, so those who may know about that system will see your post.

    But if you ever set a password, you typically need that to open additional UEFI settings. Do not know your system specifically.

    Surface Pro Ubuntu install:
    Surface Pro 3 - USB/MicroSD Only Install
    Surface Pro2 mega thread:
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Jun 2010
    London, England
    Ubuntu Development Release

    Re: Can't access items in the (GNU GRUB 2.04) UEFI Firmware Settings (Ubuntu 20.04)

    some years ago I heard of a case where the supplier set a password for what was in those days called the BIOS and refused to tell the customer what the password was. Has this happened to you?

    From the little searching I have done it seems that you can only change a UEFI password on a Surface Pro by using the present password to access the UEFI at the correct security access level.

    Microsoft says this

    • Administrator Password This option lets you create a password to prevent others from changing the UEFI settings. Organizations that need to protect sensitive information typically use an administrator password.
    Are you able to use Windows 10 to enable and disable certain items of hardware? Is this camera disabled in Windows 10?

    You can also load the UEFI firmware settings menu through Windows. To do this:
    • Select Start > Settings > Update & security > Recovery.
    • Under Advanced startup, select Restart Now.
    • Under Choose an option, select Troubleshoot > Advanced Options > UEFI Firmware Settings, and then select Restart.
    Last edited by grahammechanical; July 24th, 2020 at 12:20 AM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts