Results 1 to 1 of 1

Thread: Intel Centrino Advanced-N 6205 [Taylor Peak] / iwlwifi Intermittent Wifi Connection

  1. #1
    Join Date
    Jul 2020

    Question Intel Centrino Advanced-N 6205 [Taylor Peak] / iwlwifi Intermittent Wifi Connection

    I have a Dell Latitude E6230 running Ubuntu 20.04 (with Regolith desktop environment) which is having intermittent wifi connectivity problems. On startup the wifi will either connect, connect after 20 minutes or not connect at all. Typically once connected the connection will remain. There doesn't seem to be any particular link between what I'm doing with the laptop and whether it will connect or not - apart from it seems to know when I really want to, and therefore won't...

    In accordance with the Before posting in Networking & Wireless post I've pastebin'd my wireless-info.

    Looking through the wireless-info there is one particularly noticeable element within dmesg:

    [585.566540] iwlwifi 0000:02:00.0: Microcode SW error detected.  Restarting 0x2000000.

    I found some advice on this problem on the Linux Mint forum and therefore tried to update my microcode, downloading the la
    test version from Oregon State University FTP.

    However on running the command:

    sudo dpkg -i intel-microcode_3.20200616.1_i386.deb
    I got the following error:

    (Reading database ... 185549 files and directories currently installed.)
    Preparing to unpack intel-microcode_3.20200616.1_i386.deb ...
    Unpacking intel-microcode:i386 (3.20200616.1) over (3.20200609.0ubuntu0.20.04.2) ...
    dpkg: dependency problems prevent configuration of intel-microcode:i386:
     intel-microcode:i386 depends on iucode-tool (>= 1.0).
    dpkg: error processing package intel-microcode:i386 (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:

    So I thought well let's install iucode-tool:

    sudo apt install iucode-tool
    More errors:

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    iucode-tool is already the newest version (2.3.1-1).
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies.
     intel-microcode:i386 : Depends: iucode-tool:i386 (>= 1.0) but it is not installable
     linux-image-generic : Depends: intel-microcode but it is not going to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

    Which was weird, but I followed the advice:

    sudo apt --fix-broken install
    and got this helpful return:

    reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following additional packages will be installed:
    The following packages will be REMOVED
    The following NEW packages will be installed
    0 to upgrade, 1 to newly install, 1 to remove and 0 not to upgrade.
    1 not fully installed or removed.
    Need to get 2,525 kB of archives.
    After this operation, 230 kB disk space will be freed.
    Do you want to continue? [Y/n] y
    Get:1 focal-updates/main amd64 intel-microcode amd64 3.20200609.0ubuntu0.20.04.2 [2,525 kB]
    Fetched 2,525 kB in 0s (6,954 kB/s)       
    Selecting previously unselected package intel-microcode.
    (Reading database ... 185600 files and directories currently installed.)
    Preparing to unpack .../intel-microcode_3.20200609.0ubuntu0.20.04.2_amd64
    .deb ...
    Unpacking intel-microcode (3.20200609.0ubuntu0.20.04.2) over (3.20200616.
    1) ...
    Setting up intel-microcode (3.20200609.0ubuntu0.20.04.2) ...
    update-initramfs: deferring update (trigger activated)
    intel-microcode: microcode will be updated at next boot
    Processing triggers for initramfs-tools (0.136ubuntu6.2) ...
    update-initramfs: Generating /boot/initrd.img-5.4.0-40-generic
    I: The initramfs will attempt to resume from /dev/dm-2
    I: (/dev/mapper/vgregolith-swap_1)
    I: Set the RESUME variable to override this.

    Unfortunately on reboot that not only made no difference to my wifi problem, but I don't think it worked to update the microcode. If I try to install the downloaded microcode again I go through exactly the same error messages. Of course the microcode error could be a red herring and have nothing to do with the wifi error...

    Very grateful for any help anyone can offer.

    Last edited by hbn97kw4dp; July 8th, 2020 at 04:56 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts