Results 1 to 4 of 4

Thread: fwupdate >= 1.2.5 // Ubuntu 16.04

  1. #1
    Join Date
    Jun 2020
    Beans
    2

    fwupdate >= 1.2.5 // Ubuntu 16.04

    Hi,

    I need help... )
    On Ubuntu 16.04 systems a Lenovo firmware update (Thunderbolt etc.) is needed.
    Requirement is a fwupdate-command version >= 1.2.5.

    Currently installed on Ubuntu 16.04 is fwupdate 0.8.3 (client&daemon).

    Do anyone have an idea to run a fwupdate 1.2.5 on a Ubuntu 16.04?

    I tried already to compile the sourcecode with meson.

    Seemed to that there is a one-way. Every additionally update requires an other update and soon.

    Thanks for reading (and perhaps for an idea)

    cu
    A

  2. #2
    Join Date
    May 2010
    Beans
    338

    Re: fwupdate >= 1.2.5 // Ubuntu 16.04

    https://launchpad.net/ubuntu/+ppas?name_filter=fwupdate

    I'd recommend upgrading to Bionic (Ubuntu 18.04) which you can do online. Xenial is EOL in April next year. Bionic has a sufficient version of the package
    https://packages.ubuntu.com/search?k...ll&section=all

    You could even boot to the Bionic install CD/USB, install the fwupdate application in the live CD/USB environment, do the upgrade then reboot to the installed OS on your internal drive.

  3. #3
    Join Date
    Jun 2020
    Beans
    2

    Re: fwupdate >= 1.2.5 // Ubuntu 16.04

    Hi ActionParsnip,

    thank you for your tipps. The problem is... there are many Ubuntu 16.04 systems.
    So the USB-Boot take a lot of afford.

    The background idea was...
    install a higher version of fwupgrade-package and the firmware can be updated.
    But this isn't easy.

  4. #4
    Join Date
    May 2010
    Beans
    338

    Re: fwupdate >= 1.2.5 // Ubuntu 16.04

    Is there a PPA with the version you need using the link I gave? Remember to filter each PPA for Xenial as not all PPAs support all releases for the package you want.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •