Results 1 to 3 of 3

Thread: 20.04 Grub not working after Software Update

  1. #1
    Join Date
    Apr 2009
    Beans
    24

    20.04 Grub not working after Software Update

    During the software update today there was a problem. The system showed an error screen and then a login screen. I tried to shut down the system, but was told there was another user which blocked the shutdown. There is only one user on the system so I don't understand the message. I tried entering my password but could not log in or shut down. Finally I pressed the power key to switch off the laptop.
    When I tried to log in there was no Grub menu; just an entry grub> .

    I was able to get the system running again with the 20.04 installation CD under "Try Ubuntu", and installing Boot Repair as described in the Ubuntu Community documentation. The Boot Repair found my /boot partition and repaired Grub.

    There was a similar problem with the latest software update on my wife's computer, with an error screen and a login screen. In this case switching off the computer did not cause a problem with Grub.

    Anyone have any similar problems or suggestions how to find what went wrong?

  2. #2
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: 20.04 Grub not working after Software Update

    What error screen did you see?

    We need more info to be able to help; what updates were there?
    You can find the packages upgraded from the /var/log/dpkg.log files and use grep on them to see the upgrades with command
    grep upgrade /var/log/dpkg.log

  3. #3
    Join Date
    Apr 2009
    Beans
    24

    Re: 20.04 Grub not working after Software Update

    The attached Updates.txt shows all the lines with Updates starting this morning. I also added the last few lines of dpkg.log at the end. The last readable line shows "2020-06-28 07:15:37 status half-configured grub-efi-amd64-signed:amd64 1.142.1+2.04-1ubuntu26". The last line shows as "\00\00\00\...." but I could not copy it.
    It seems that the system was configuring grub and there was a kernel crash.
    In case it is helpful, I also attached the part of syslog for the time of the update. This file also ended in "\00\00\00\00....".
    Attached Files Attached Files

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •