Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: HPLIP 3.20.6 Installation Problem

  1. #11
    Join Date
    Jul 2009
    Beans
    52

    Re: HPLIP 3.20.6 Installation Problem

    Quote Originally Posted by dragonfly41 View Post
    I have just completed a troubleshooting exercise of comparing my old /etc/cups (working on Ubuntu 16.04) configuration with my new /etc/cups (not working on Ubuntu 18.04) configuration.

    Started from the point where printer was not detected in localhost:631.

    I have Krusader installed as a file manager and with two panes it is easier to compare old directory with new. I observed differences in file sizes and some files were missing in my new configuration.

    I also noticed there is /etc/cupshelpers folder alongside /etc/cups.

    To cut a long story short I changed the folder names in my new directory to /etc/_cups and /etc/_cupshelper just to back them up.

    Next I copied /etc/cups and /etc/cupshelpers from old (16.04) to new (18.04).
    For good measure I restarted Ubuntu.

    And on viewing localhost:631 I was back in business. Printer showed in browser.
    Did you have 16.04 and 18.04 on your computer at the same time? I only installed 20.04 on mine and no other Ubuntu version. Indeed, I reinstalled it today to start with a clean slate with regards to a printer installation using HPLIP 3.20.3, adding Cinnamon and LXDE as I went along.

    Which brings me to a clue that might interest you. When I plugged my printer into an USB port after the reinstallation, the 'system-config-printer' program detected it as a network printer, signalling that it is connected to localhost, but when I went to localhost:631 and pressed the "Find New Printers" button, the aforementioned 'No Printers Found' error message appeared. Also, when I clicked on the "Add Printer" button, this came up:

    http://localhost:631 is requesting your username and password. The site says: "CUPS"

    Perhaps using my printer as a Network printer might be an avenue I can pursue? I could devise my own username and password in the process. I was using the Cinnamon desktop environment at the time I plugged the printer into the USB port if it matters. Also, when I click on the "Manage Printers" button, my printer does show up.
    Last edited by and003; June 21st, 2020 at 08:19 PM. Reason: Username and Password suggestion.

  2. #12
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: HPLIP 3.20.6 Installation Problem

    Did you have 16.04 and 18.04 on your computer at the same time?
    Sorry, I should have explained that I have an old Ubuntu 16.04 installed alongside Windows 10 in /dev/sda
    and in /dev/sdb I have Ubuntu 18.04 installed on an SSD in a docking bay. This way I can refer back to old installations.

    I have solved my problem of missing printer and I posted the above workflow not as a question but perhaps to help you in your troubleshooting.

    ...

    However, although my printer is recognised I have just tried printing and I get this message ..

    "The PPD version (5.2.11) is not compatible with Gutenprint 5.2.13. Please run `/usr/sbin/cups-genppdupdate' as administrator."

    Updated /etc/cups/ppd/HP-LaserJet-2100M.ppd using gutenprint.5.2://hp-lj_2100m/expert
    Updated 1 PPD file. Restart cupsd for the changes to take effect.

    That works and I printed my job.
    Last edited by dragonfly41; June 21st, 2020 at 09:26 PM. Reason: latest status

  3. #13
    Join Date
    Jul 2009
    Beans
    52

    Re: HPLIP 3.20.6 Installation Problem

    I've discovered something about my XSane installation that might be connected. When I tried using it without HPLIP, I received this error message:

    Failed to open device 'hpaio:/usb/Smart_Tank_Plus_650_series?serial=CN9B8240ZR': Error during device I/O.

    Perhaps the answer lies in this particular issue?

  4. #14
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: HPLIP 3.20.6 Installation Problem

    I'm sorry I can't throw some more ideas into the pot.

  5. #15
    Join Date
    Jul 2009
    Beans
    52

    Re: HPLIP 3.20.6 Installation Problem

    Quote Originally Posted by dragonfly41 View Post
    I'm sorry I can't throw some more ideas into the pot.
    That's okay. I'm certain if I can figure out how to change the driver through the HPLIP interface, the problem should clear up. It will mean contacting the people at HPLIP for assistance, though. In the meantime, I can use other programs for scanning and printing.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •