Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Anydesk install in 20.04 64bit on a Pi 4

  1. #11
    Join Date
    Jun 2020
    Beans
    11

    Re: Anydesk install in 20.04 64bit on a Pi 4

    Ok. I removed the ppa

    Code:
    sudo add-apt-repository --remove ppa:rpi-distro/ppa
    then launched anydesk via terminal.

    Code:
    anydesk
    Code:
    /usr/bin/anydesk
    In both cases it said:
    error while loading shared libraries: libpolkit-gobject-1.so.0: cannot open shared object file: No such file or directory

    200608_screenshot_02.jpg

  2. #12
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,727
    Distro
    Ubuntu

    Re: Anydesk install in 20.04 64bit on a Pi 4

    Try installing the libpolkit-gobject package
    Code:
    sudo apt-get install libpolkit-gobject-1-0
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #13
    Join Date
    Jun 2020
    Beans
    11

    Re: Anydesk install in 20.04 64bit on a Pi 4

    I did a search and found this:
    https://stackoverflow.com/questions/...raries-libpolk

    So i did this:
    Code:
    apt-get install libpolkit-gobject-1.so.0
    but got this for my trouble:

    E: Unable to locate package libpolkit-gobject-1.so.0
    E: Couldn't find any package by glob 'libpolkit-gobject-1.so.0'
    E: Couldn't find any package by regex 'libpolkit-gobject-1.so.0'


    I thought i was onto something there for a moment

    200608_screenshot_03.jpg

  4. #14
    Join Date
    Jun 2020
    Beans
    11

    Re: Anydesk install in 20.04 64bit on a Pi 4

    Quote Originally Posted by deadflowr View Post
    Try installing the libpolkit-gobject package
    Code:
    sudo apt-get install libpolkit-gobject-1-0
    Ok, tired this too and it said:

    ibpolkit-gobject-1-0 is already the newest version (0.105-26ubuntu1).

    Still no joy.

    200608_screenshot_04.jpg

  5. #15
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    11,727
    Distro
    Ubuntu

    Re: Anydesk install in 20.04 64bit on a Pi 4

    Might be it needs the armhf version.
    Try
    Code:
    sudo apt-get install libpolkit-gobject-1-0:armhf
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  6. #16
    Join Date
    May 2010
    Beans
    964

    Re: Anydesk install in 20.04 64bit on a Pi 4

    To access the files on your pi from your tablet etc you can install openssh-server and you will get an SFTP service. You can connect to this from Windows and tablets and use your Raspberry Pi credentials to authenticate. You can also use SSH (like PuTTY) to connect to the server and manipulate the OS in CLI (Software updates are dead handy here).

  7. #17
    Join Date
    Jun 2020
    Beans
    11

    Re: Anydesk install in 20.04 64bit on a Pi 4

    Quote Originally Posted by deadflowr View Post
    Might be it needs the armhf version.
    Try
    Code:
    sudo apt-get install libpolkit-gobject-1-0:armhf
    Ok, this time it did something:

    The following NEW packages will be installed:
    libpolkit-gobject-1-0:armhf
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.

    But still failed to open:
    Code:
    anydesk
    as it gave this new error:
    anydesk: error while loading shared libraries: libbcm_host.so: cannot open shared object file: No such file or directory

    200608_screenshot_05.jpg

  8. #18
    Join Date
    May 2010
    Beans
    964

  9. #19
    Join Date
    Jun 2020
    Beans
    11

    Re: Anydesk install in 20.04 64bit on a Pi 4

    after reading these i tired this but it didn't work.
    Code:
    sudo apt-get update
    sudo apt-get install --reinstall libraspberrypi0 libraspberrypi-dev libraspberrypi-doc libraspberrypi-bin

    200608_screenshot_06.jpg

  10. #20
    Join Date
    Jun 2020
    Beans
    11

    Re: Anydesk install in 20.04 64bit on a Pi 4

    and found my way to this page:
    https://github.com/raspberrypi/firmware/releases

    Since my Opt/vc folder is empty i tried to get Ark to extract the Opt/vc folder from the archive (firmware-1.20200601-arm64.tar.gz) but i don't have sufficient permissions.

    200608_screenshot_06.jpg
    Attached Images Attached Images

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •