Results 1 to 5 of 5

Thread: Specific version of "activation of network connection failed" under Ubuntu 18.04

  1. #1
    Join Date
    Jun 2020
    Beans
    4

    Specific version of "activation of network connection failed" under Ubuntu 18.04

    I have found many earlier questions here that at first glance, describe the same problem I am facing: I get the error message `activation of network connection failed` when trying to connect to any Wi-Fi network.

    However, in comparison to earlier questions I have found, my case is rather particular in a few ways:


    • this problem appeared out of a sudden, after I rebooted my computer - that is, everything was working fine for more more than an year until minutes ago (also, I did **not** install any new software recently);



    • I can still see all available Wi-Fi connections listed, but upon selection any, I get the above mentioned error message (I did try forgetting/re-entering connections);



    • my Wi-Fi card (the one that has smoothly worked in the last year) is a PCI Express Wi-Fi adapter (so the discussion https://askubuntu.com/questions/1214...nection-failed does not help). More specifically, it is a FebSmart Wireless Dual Band N600 (2.4GHz 300Mbps or 5GHz 300Mbps). For reference, a `lshw` gives me the following wi-fi network (i.e. omitting Ethernet cards):



    Code:
     *-network
      description: Wireless interface
      product: AR93xx Wireless Network Adapter
      vendor: Qualcomm Atheros
      physical id: 0
      bus info: pci@0000:02:00.0
      logical name: wlp2s0
      version: 01
      serial: e0:ca:94:c5:b0:57
      width: 64 bits
      clock: 33MHz
      capabilities: bus_master cap_list rom ethernet physical wireless
      configuration: broadcast=yes driver=ath9k driverversion=5.3.0-53-generic firmware=N/A latency=0 link=no
      multicast=yes wireless=IEEE 802.11
      resources: irq:16 memory:dfe00000-dfe1ffff memory:dfe20000-dfe2ffff
    Other relevant outputs:

    Code:
    description: Computer
      width: 64 bits
      capabilities: smp vsyscall32   *-core
      description: Motherboard
      physical id: 0
      *-memory
      description: System memory
      physical id: 0
      size: 251GiB
    
      *-cpu:0
      product: Intel(R) Xeon(R) CPU E5-2697 v2 @ 2.70GHz
      vendor: Intel Corp.
      physical id: 1
      bus info: cpu@0
      size: 1611MHz
      capacity: 3500MHz
      width: 64 bits
      capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge > mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm cpuid_fault epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts md_clear flush_l1d cpufreq
    
      *-cpu:1
      product: Intel(R) Xeon(R) CPU E5-2697 v2 @ 2.70GHz
      vendor: Intel Corp.
      physical id: 2
      bus info: cpu@1
      size: 2130MHz
      capacity: 3500MHz
      width: 64 bits
      capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm cpuid_fault epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts md_clear flush_l1d cpufreq
    And a `iwconfig`gives me:

    Code:
     wlp2s0    IEEE 802.11  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:off
      enp6s0    no wireless extensions.
      
      enp7s0    no wireless extensions.
      
      lo        no wireless extensions.
      
      enp9s0    no wireless extensions.
      
      enp10s0   no wireless extensions.








    • importantly, I have borrowed a USB TP-LINK Wi-Fi adapter (model TL-WN722N) from a friend and plugged into my machine - and with it, I can connect immediately to any Wi-Fi network;



    So, my question to my fellow Ubuntu users: what should I do to try to restore access through my PCI Express card, as I was just having minutes ago?
    Last edited by wildmanne39; 4 Weeks Ago at 01:00 AM. Reason: Added code tags

  2. #2
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    28,679
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Specific version of "activation of network connection failed" under Ubuntu 18.04

    Please use code tags - if you are using New Reply button - highlight text and use the # button in the text box header.

    If using Quick Reply then [code] at the beginning and [/code] at the end.

    Hi, please click on the wireless script in my signature, follow the directions to run it and post the results back here using the pastebin link created.

  3. #3
    Join Date
    Jun 2020
    Beans
    4

    Re: Specific version of "activation of network connection failed" under Ubuntu 18.04

    Quote Originally Posted by wildmanne39 View Post
    Please use code tags - if you are using New Reply button - highlight text and use the # button in the text box header.

    If using Quick Reply then [code] at the beginning and [/code] at the end.

    Hi, please click on the wireless script in my signature, follow the directions to run it and post the results back here using the pastebin link created.
    Apologies for the originally wrong tag and thanks both for correcting it and for pointing me to the mentioned script.
    Here you have my pastebin link: https://pastebin.com/ZKZ9zfVb

    Whoever looks at that log: be aware that, as described in the OP, I am using a borrowed USB TP-Link Wi-Fi adapter to connect to internet while I solve this issue. Hence, in the logs, you may see such a device as well. But the help I need is for making everything work, as it was working until a few hours ago, with the PCI Express Wi-Fi adapter you see in the logs.


    Thanks in advance for any help you or other may be able to provide.

  4. #4
    Join Date
    Jun 2020
    Beans
    4

    Re: Specific version of "activation of network connection failed" under Ubuntu 18.04

    Hi all, just to add so those who can potentially help me have this extra information. A new symptom showed up: now with the borrowed USP adapter described above, from time to time all Wi-Fi connections stop being recognized and I have to manually restart the Network Manager.

  5. #5
    Join Date
    Jun 2020
    Beans
    4

    Re: Specific version of "activation of network connection failed" under Ubuntu 18.04

    I am still have the same issues. Help is desperately needed, so I am bumping this up.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •