Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: ubuntu server failed to start network time syncronisation

  1. #1
    Join Date
    Jun 2020
    Beans
    11

    Exclamation ubuntu server failed to start network time syncronisation

    Hello,

    I have a server with ubuntu 18.04.4 installed. The server was working fine, no errors or issues.

    This morning I decided to install Samba to share some stuff over my network, I installed and configured everything and it worked fine.
    After the installation I shutdown the server and when I try to boot back up i get the following error:
    Code:
    [ERROR] failed to start Network Time sycronisation
    and many others cause by that error, this leads to a loop and it's impossible for the machine to boot.

    I tried the following things:
    • Booting into recovery mode and trying to enable networking, nothing happens, no errors but networking is not enabled
    • When I do ifconfig I have no network interfaces
    • Using the lspci command returns the output i was expecting, all 4 interfaces are there so I assume it's not a hardware issue
    • Eth0,1,2,3 are nowhere to be found in /etc/network/interfaces and even adding eth0 manually doesn't change a thing


    If this is the wrong place to post this I'm sorry, I will move this in another place, it's my first post on the forum so please be kind.

  2. #2
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    1,351
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: ubuntu server failed to start network time syncronisation

    I assume you have Ubuntu installed on bare-metal (physical) machine rather than inside a virtual machine.

    Is the BIOS time correct? If the CMOS battery is dead, it is possible that the year gets reset to 1980 which can cause havoc on a system.

    If the system is not showing any ethernet devices, I have to wonder if something got corrupted or if your motherboard is failing.

    I would stick a CD-ROM into the drive that has Ubuntu Desktop on it and see if that boots up in a "try-before-you-buy" scenario without installing. Then see if the CD version can see the network device(s) to see if we are looking at a configuration/corruption problem or if your hardware is failing.

    EDIT: Because you made recent changes (installed Samba), there is a high likelihood that commands you issued (or changes made to files) caused the problem. So if hardware is not the problem and Ubuntu live image is running, mount the root file system and look at the home directory of the user you used to issue those commands and examine the ~/.bash_history file to see the commands you issued to see if that clues you into the problem area.

    LHammonds
    Last edited by LHammonds; June 1st, 2020 at 03:53 PM.

  3. #3
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,056
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: ubuntu server failed to start network time syncronisation

    Let's see the results of these commands:

    Code:
    date
    sudo hwclock
    You could make your server an NTP server by installing the ntp package. Then it will synchronize itself with other Internet time servers.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  4. #4
    Join Date
    Jun 2020
    Beans
    11

    Re: ubuntu server failed to start network time syncronisation

    Thanks for the answer:
    • I checked on the bios and the date and time are fine, the time zone it's wrong (could this be the cause?)
    • I booted a usb media with ubuntu live and all the ethernet intefaces are recognised
    • I checked my bash_history file for both root and my user and there is nothing that could cause any issue, the last root command is the reboot command (idk why i did sudo su instead of simply sudo but doesn't seem like i did anything before that with root user)
    • date and hwclock ouputs are the same as the bios clock


    Changing the bios time with the correct one didn't resolved the issue

    EDIT:
    I just remembered that I enabled ufw before rebooting, could this be a firewall issue? -> disabling ufw didn't change a thing
    Last edited by arthurd3nt; June 1st, 2020 at 07:11 PM.

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,056
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: ubuntu server failed to start network time syncronisation

    If you have no network interfaces, that's the problem, and it's much bigger than just time sync.

    18.04 uses netplan, not /etc/network/interfaces, to activate interfaces and assign them IP addresses. See https://linuxconfig.org/how-to-confi...c-beaver-linux or an equivalent HOWTO.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    1,351
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: ubuntu server failed to start network time syncronisation

    Wait a second, you were looking for network settings in /etc/network/interfaces?

    That is the default location for Ubuntu 16.04 and lower. Since 18.04, the default has been the use of Netplan and its configuration file is located in /etc/netplan/

    The command to see your IP address for 18.04+ (assuming you did not change the network software) is:

    Code:
    ip address
    ifconfig is still installed by default (i think) on 18.04 but is not part of the base install in 20.04 (you would have to install net-tools to get it now).

    EDIT: An example of how I setup netplan can be found here.

    LHammonds
    Last edited by LHammonds; June 1st, 2020 at 09:33 PM. Reason: Added URL

  7. #7
    Join Date
    Jun 2020
    Beans
    11

    Re: ubuntu server failed to start network time syncronisation

    Thanks again for the answers.

    ip address outputs this:
    WhatsApp Image 2020-06-02 at 09.40.57.jpg

    ifconfig outputs this:
    WhatsApp Image 2020-06-02 at 09.40.57 (1).jpg

    The netplan config file is:
    Code:
    network:
      version: 2
      renderer: networkd
      ethernets:
        eno1:
          dhcp4: true
        eno2:
          dhcp4: true
        eno3:
          dhcp4: true
        eno4:
          dhcp4: true
    Now I edited it to this:
    Code:
    network:
      version: 2
      renderer: networkd
      ethernets:
        eno1:
          dhcp4: no
          addresses: [172.16.0.209/24]
          gateway4: 172.16.0.1
          nameservers:
            addresses: [8.8.8.8,8.8.4.4]
        eno2:
          dhcp4: true
        eno3:
          dhcp4: true
        eno4:
          dhcp4: true
    because eno1 is the only one connected

    Doing "netplan --debug generate" outputs this:
    WhatsApp Image 2020-06-02 at 09.26.39.jpg

    I rebooted and still no changes.
    Last edited by arthurd3nt; June 2nd, 2020 at 10:03 AM.

  8. #8
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    1,351
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: ubuntu server failed to start network time syncronisation

    Let's verify the network card name (they might not be eno), here is how you can get a network device name list:

    Code:
    ls /sys/class/net
    ens32  lo
    And here is how you can get the status of each device:

    Code:
    ip -o link show | awk '{print $2,$9}'
    lo: UNKNOWN
    ens32: UP
    LHammonds

  9. #9
    Join Date
    Jun 2020
    Beans
    11

    Re: ubuntu server failed to start network time syncronisation

    The outputs of what you told me to do are these:
    WhatsApp Image 2020-06-02 at 14.33.43.jpg

    Thanks again

  10. #10
    Join Date
    Sep 2011
    Location
    Behind you!
    Beans
    1,351
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: ubuntu server failed to start network time syncronisation

    Ok, so we are looking at physical layer 1 issue which means we need to verify that the cable is plugged in and working (maybe even swap the network cable or plug into a different port in the switch). But the 1st and easiest thing to try first is to make sure it is even enabled.

    You said eno1 is the device that should be in use so let's make sure it is enabled:
    Code:
    ip link set eno1 up
    Check status with:
    Code:
    ip -br link show
    If that makes no difference in status, check/trace the physical hardware.

    LHammonds
    Last edited by LHammonds; June 2nd, 2020 at 02:07 PM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •