Results 1 to 8 of 8

Thread: Xubuntu new install not booting on Toshiba laptop

  1. #1
    Join Date
    May 2020
    Beans
    3

    Xubuntu new install not booting on Toshiba laptop

    I created a bootable USB with 64-bit xubuntu 16.04 LTS a few years ago and used it to put xubuntu onto an ASUS laptop at the time with no problems.
    I have now tried to put it onto a Toshiba Satellite C50 - no hard drive partitions.
    It boots from the USB fine and seems to run through the install. However, when it restarts it just boots from the USB still even though I changed the boot order back to HDD.
    When I remove the USB it gets stuck on the Toshiba start up image and doesn't boot at all.

  2. #2
    Join Date
    Jun 2019
    Location
    Dirndl-land
    Beans
    428
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: Xubuntu new install not booting on Toshiba laptop

    Did you format the partition(s) during install? You should normally format as ext4.
    After the install is through, it normally prompts you to remove the installation media (USB stick)

    That apart, 16.04 LTS is not really up to date, 20.04 LTS is there now.

  3. #3
    Join Date
    May 2020
    Beans
    3

    Re: Xubuntu new install not booting on Toshiba laptop

    Quote Originally Posted by ml9104 View Post
    Did you format the partition(s) during install? You should normally format as ext4.
    After the install is through, it normally prompts you to remove the installation media (USB stick)

    That apart, 16.04 LTS is not really up to date, 20.04 LTS is there now.
    Thank you - I didn't't do anything with the partition before installing as there is only one partition present... how can I rectify this now as the laptop will only boot from the usb?

  4. #4
    Join Date
    Sep 2009
    Location
    Pennsylvania
    Beans
    3,183
    Distro
    Xubuntu

    Re: Xubuntu new install not booting on Toshiba laptop

    If you are using the entire disk, then you do not need to specify the partitions or anything else. I would start with d-ling 20.04 since there are many newer drivers in that than in the 4 year old OS you are trying to make work.

  5. #5
    Join Date
    Jun 2019
    Location
    Dirndl-land
    Beans
    428
    Distro
    Lubuntu 20.04 Focal Fossa

    Re: Xubuntu new install not booting on Toshiba laptop

    Quote Originally Posted by hannahldr View Post
    Thank you - I didn't't do anything with the partition before installing as there is only one partition present... how can I rectify this now as the laptop will only boot from the usb?
    You don't need to do anything before the install. After landing on the live desktop and starting the install, the installer will suggest that you format the HDD. In that case, select ext4.

    Any error messages?
    Last edited by ml9104; May 31st, 2020 at 10:26 PM.

  6. #6
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Xubuntu new install not booting on Toshiba laptop

    Did you install in one boot mode, UEFI or BIOS, but system is set to boot in other mode?

    Not sure if this model is similar or not:
    Toshiba Satellite P50 model number: P50-A-01E Haswell processor
    http://ubuntuforums.org/showthread.php?t=2163854
    Turned NIC (Integrated Network Interface Controller) off and then booted off of USB. Was NOT an issue with any Linux distro just a quirk of the laptop.
    Am now running 13.10 daily and everything works. Also had to stick with EFI boot ON, Secure Boot disabled. Wouldn't boot off of any media or HDD when mode set to CSM.
    Another users in same thread used Legacy mode and then NIC worked.
    Toshiba P50 reset with pin hole on bottom
    after tinkering, found a little pinhole on the bottom of the laptop next to the RAM. used a paperclip to press it and now the BIOS is working again.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  7. #7
    Join Date
    May 2020
    Beans
    3

    Re: Xubuntu new install not booting on Toshiba laptop

    Thanks for the replies - I created a xubuntu 20.04 bootable usb and loaded this onto the laptop. All went well and the OS worked immediately after installation with usb removed. However, tried to turn laptop on the next day and back to square one - not booting at all. Stuck on the toshiba startup page...
    I've seen some of the other threads mention NIC - how do I go about changing this when the furthest I can get on the computer is the BIOS menu?

  8. #8
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Xubuntu new install not booting on Toshiba laptop

    The link above was just to prevent it from trying to boot from network first, not USB. But then you turn network back on in UEFI/BIOS.

    Do settings in UEFI match your install? UEFI or BIOS boot?
    Have you updated UEFI to latest available from Toshiba?
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •