Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

  1. #11
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,293
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    Quote Originally Posted by tomsax View Post
    Oh I see I can go to into my route. I'm sure I should know that. I have now gone in and changed some things making only 20 Mhz possible and not other option. I'll see if that helps.
    Please review my answer above. Please make all of the changes that I recommended in the router.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  2. #12
    Join Date
    Dec 2008
    Beans
    117

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    The good news is that when the wifi is working, it is working and not dropping off now. Thanks very much chilli555 for your help and undestanding. The bad thing is that sometimes when I boot up on ubuntu there is no wifi at all. It says "no router available/detected" or such like.

    Usually when I restart and boot up again it is then there but it is still a pain.

    Any info on how to get it working without rebooting or how to solve this problem?

  3. #13
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,293
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    Is this a dual boot with Windows? Could this be the issue? https://wireless.wiki.kernel.org/en/...t-boot_enabled

    When there is no wireless, what does this tell us?

    Code:
    lsmod | grep iwl
    dmesg | grep -e iwl -e 14.3
    it is working and not dropping off now.
    Awesome! That's great news.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  4. #14
    Join Date
    Dec 2008
    Beans
    117

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    Hi,

    Sorry I have been distracted by work. it doesnt seem to be the fast boot issue.

    I run the commannds and copy results below:

    tom@tom-Aspire-A514-52:~$ lsmod | grep iwl
    iwlmvm 380928 0
    mac80211 843776 1 iwlmvm
    iwlwifi 331776 1 iwlmvm
    cfg80211 704512 3 iwlmvm,iwlwifi,mac80211
    tom@tom-Aspire-A514-52:~$ dmesg | grep -e iwl -e 14.3
    [ 0.048191] Memory: 3643116K/3890164K available (14339K kernel code, 2397K rwdata, 4952K rodata, 2712K init, 4992K bss, 247048K reserved, 0K cma-reserved)
    [ 0.142322] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.XHC.RHUB.HS01._UPC], AE_ALREADY_EXISTS (20190816/dswload2-326)
    [ 0.142324] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
    [ 0.142325] ACPI: Skipping parse of AML opcode: Method (0x0014)
    [ 0.142326] ACPI BIOS Error (bug): Failure creating named object [\_SB.PCI0.XHC.RHUB.HS01._PLD], AE_ALREADY_EXISTS (20190816/dswload2-326)
    [ 0.142328] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20190816/psobject-220)
    [ 0.142329] ACPI: Skipping parse of AML opcode: Method (0x0014)
    [ 0.214231] pci 0000:00:14.2: [8086:02ef] type 00 class 0x050000
    [ 0.215082] pci 0000:00:14.3: [8086:02f0] type 00 class 0x028000
    [ 0.215107] pci 0000:00:14.3: reg 0x10: [mem 0x91318000-0x9131bfff 64bit]
    [ 0.215265] pci 0000:00:14.3: PME# supported from D0 D3hot D3cold
    [ 0.291413] clocksource: Switched to clocksource tsc-early
    [ 2.843105] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-50.ucode failed with error -2
    [ 2.843425] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-49.ucode failed with error -2
    [ 2.845858] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 43.2.23.17
    [ 2.845862] iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
    [ 2.845863] iwlwifi 0000:00:14.3: Found debug configuration: 0
    [ 2.846260] iwlwifi 0000:00:14.3: loaded firmware version 48.4fa0041f.0 op_mode iwlmvm
    [ 2.885075] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x354
    [ 2.893120] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
    [ 2.894374] iwlwifi 0000:00:14.3: Allocated 0x00400000 bytes for firmware monitor.
    [ 3.038833] iwlwifi 0000:00:14.3: base HW address: 04:33:c2:b9:4b:28
    [ 3.291476] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0
    [ 5.259235] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
    [ 5.403700] iwlwifi 0000:00:14.3: FW already configured (0) - re-configuring
    [ 5.414590] iwlwifi 0000:00:14.3: BIOS contains WGDS but no WRDS
    tom@tom-Aspire-A514-52:~$

  5. #15
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,293
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    [ 2.846260] iwlwifi 0000:00:14.3: loaded firmware version 48.4fa0041f.0 op_mode iwlmvm
    [ 2.885075] iwlwifi 0000:00:14.3: Detected Intel(R) Wi-Fi 6 AX201 160MHz, REV=0x354
    [ 2.893120] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
    [ 2.894374] iwlwifi 0000:00:14.3: Allocated 0x00400000 bytes for firmware monitor.
    [ 3.038833] iwlwifi 0000:00:14.3: base HW address: 04:33:c2:b9:4b:28
    [ 3.291476] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0
    Nothing here suggests that the wireless is not working as expected. Does the interface show up here?

    Code:
    ip addr show
    Does it scan and see networks?

    Code:
    nmcli device wifi list
    Is the Network Manager icon present?



    Is Network Manager running?

    Code:
    ps aux | grep etwork
    Does it try but fail to connect?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  6. #16
    Join Date
    Dec 2008
    Beans
    117

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    It was working when I ran that command. Its just when I boot up from dual boot sometimes there is no wifi icon, no wifi and I have to reboot again. Then it usually appears on second attempt. I think when I look for wifi it says "no adaptor detected" or such like.

    I'll try those commands tonight and tell you what I get tonight or tomorrow.

    Tom

  7. #17
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,293
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    Quote Originally Posted by tomsax View Post
    It was working when I ran that command. Its just when I boot up from dual boot sometimes there is no wifi icon, no wifi and I have to reboot again. Then it usually appears on second attempt. I think when I look for wifi it says "no adaptor detected" or such like.

    I'll try those commands tonight and tell you what I get tonight or tomorrow.

    Tom
    Did you check Fast Boot as I suggested in post #13?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  8. #18
    Join Date
    May 2013
    Location
    Galiza
    Beans
    1,901
    Distro
    Ubuntu

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    It seems the issue isn't about Fast Boot (UEFI feature, OS agnostic) but Fast Startup (Windows feature). In the link the terms are used interchangeably where they shouldn't:

    About dual-boot with Windows and "fast-boot" enabled

    If you have a dual-boot machine with a recent version of Windows and start seeing problems during initialization of the WiFi device when booting Linux, the problem could be due to the “fast startup” feature on Windows.
    It's always recommended to disable Fast Startup when dual-booting and arguably also with Windows alone.

  9. #19
    Join Date
    Dec 2008
    Beans
    117

    Re: Wireless drops on Ubuntu 20.04 on Acer Aspire 5 A514-52

    Finally managed to sort this out using the above (re: fast boot). Many thanks for your help.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •