Results 1 to 4 of 4

Thread: Cannot boot from USB on Intel NUC

  1. #1
    Join Date
    Apr 2020

    Cannot boot from USB on Intel NUC

    Intel NUC model NUC8BEB

    I tried to install the Gnome Desktop on my NUC running Ubuntu Server using tasksel. When I reboot, everything goes to heck.

    The error message is:
    CIFS VFS: CIFS mount error: iocharset utf8 not found

    I can log in on my admin account, but nothing will run.

    I am assuming that fixing this will require reinstalling Ubuntu. But I have tried for hours to get the NUC to boot from the thumbdrive. Nothing works.

    I downloaded the latest Ubuntu iso image ( and used Rufus to make a bootable drive. (Twice).
    I hit F10 during the NUC boot and selected the USB drive.
    But the NUC still boots from the M2 drive.

    Help, please.

  2. #2
    Join Date
    Mar 2011

    Re: Cannot boot from USB on Intel NUC

    Seems like there are a few problems here. First, did you hashcheck the downloaded ISO and run a media check on the USB if offered? A bad download or USB might explain not being able to boot from the USB. Next, Ubuntu Server needs a lot of support for the Gnome Desktop, like X for instance. might as well start with the desktop, which does all that. Then delete pakcages you don't need or want.

  3. #3
    Join Date
    Jun 2009
    SW Forida

    Re: Cannot boot from USB on Intel NUC

    I do not know NUC models, but there seem to be some issues with them.
    this Network adapter Intel Corporation Device [8086:0d4f] is new and supported by mainline Linux kernel since the 5.5 Linux kernel.

    How to install Bionic on Hades Canyon (nuc8i7hvk/nuc8i7hnb) with Vega M GPU support - using ppa
    Updated drivers for Hades Canyon
    Intel NUC
    Certified ISO & Instructions
    intel nuc - nuc5i5MYHE w/M.2 SSD
    boot into the EFI shell and manually point startup.nsh to the grubx64.cfg and run it
    Running The Intel NUC6i7KYK On Linux With Skylake Iris Pro Graphics 16.10
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #4
    Join Date
    Apr 2020

    Re: Cannot boot from USB on Intel NUC

    Thanks ubfan1. I did not hashcheck the download- it's never been a problem, but I will try anything.

    I am able to log in as admin, and I was able to copy my home, etc, lib, usr and var folders to a mounted SSD.

    My intent is to simply reinstall Ubuntu and spend tomorrow to reconfigure everything. But, if I can't get the NUC to boot from the USB, what can I do?

    I got a bit further with a new USB drive.
    It looked like it was going to boot and install from the thumb drive, but I am now getting:
    "ubuntu 18.04 started wait until snapd is fully seeded"

    All I can see from Google is that this was fixed in 18.04.4

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts