Results 1 to 1 of 1

Thread: Extremely long time to format external SSD. Is this normal?

  1. #1
    Join Date
    May 2020

    Extremely long time to format external SSD. Is this normal?

    Hi. I'm relatively new to Ubuntu and Linux. I switched over from Windows a few weeks ago. And I'm having an unusual experience trying to format a 1 TB external SSD using the GUI tool that came with my installation ("Disks"). I chose the ext4 filesystem with the LUKS ecryption and disk wipe options. I'm approaching 36 hours now; and the job still isn't finished. I know that encryption and disk erasure can take time. But I've never seen anything like this before... I've previously wiped and encrypted drives twice as large in half the time (using Veracrypt for example). Is it possible that this utility is bugged? Or is it normal for the format/encrypt/erasure process to take this kind of time? I don't want to unplug the drive, and interrupt the process. But I'm starting to wonder if something's not right. Thanks for any help you can give.

    Edit: Nevermind... It just occured to me that you can't overwrite an SSD the same way you can overwrite a HDD. That was the problem... I removed the drive and tried again on a different one (without the "erase" option selected). It was finished in under a minute. Then I went back to the original drive and got the same result.
    Last edited by j-cedarstrom; 2 Weeks Ago at 06:58 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts