I'm a bit of a linux newbie, using Pop!_OS, and having an issue that I can't figure out. Every Pop!_os related forum, and chat where I've presented this problem, no one could advise me, and could only tell me they didn't have any experience with SATA hot swap.


An SATA port on my board that has hotswap enabled in the UEFI acts like it's not swappable, never shows as a removable device, always shows corrupted partition tables/disks, when in Pop, and never shows a properly working disk. The attached device is an SATA Hot Swap bay, and works normally in Windows. board is a ROG Strix Z390-F Gaming Motherboard, and I'm using kde on Pop!_OS 20.04, but same issues in pop's default DE.


a GPT formatted disk was recently tried, but showed a corrupted partition table. When i tried using testdisk on it, it told me it saw a MSDOS partition table that was corrupted. I immediately pulled the disk, and placed it into a USB swap caddy. The disk worked, and all partitions were usable as expected.


This feature works perfectly in Windows. Is it possible this board is just too new, and I'd be better off just going back to Windows for now? I use the device a LOT, so not having it for use will make me fall back to Windows. As a reference, I just upgraded from a 5 year old gigabyte board, which had the same feature, and worked flawlessly in Pop!_OS.

This is a fresh, clean install. I didn't carry over my home directory, or any config files.