Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Unable to upgrade VirtualBox

  1. #1
    Join Date
    Apr 2006
    Beans
    2,673

    Unable to upgrade VirtualBox

    Hi all,

    VirtualBox 6.0
    Host OS - Ubuntu 18.04

    This is a spare desktop PC, having NOT been run for about a month. On starting VirtualBox I'm asked to upgrade to a new version of VirtualBox. On clicking to accept it finally a warning popup
    Code:
    The network operation failed with the following error: 
    During network request: SSL authentication failed.
    This is NOT the first time I'm asked to upgrade VirtualBox on this PC but it is my first time encountering this problem.

    I have been searching a while on Internet discovering several links having similar problem. Please advise how to fix it.

    Thanks

    Regards
    satimis

  2. #2
    Join Date
    Jun 2016
    Beans
    1,989
    Distro
    Xubuntu 20.04 Focal Fossa

    Re: Unable to upgrade VirtualBox

    What version of VirtualBox are you trying to upgrade to?
    Does it work for you to manually download the new version from the official website, apt-get purge the existing VirtualBox, then install the new version?

  3. #3
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,055
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Unable to upgrade VirtualBox

    Follow the procedure described here

    https://www.virtualbox.org/wiki/Linu...xdistributions

    to add Oracle's repository to your system. Next remove your current virtualbox installation with

    Code:
    sudo apt purge virtualbox
    then install VB 6.1 with

    Code:
    sudo apt update
    sudo apt install virtualbox-6.1
    Your system will upgrade VB automatically when needed just like it updates software in the Ubuntu repositories.

    After you've finished and VB works as expected, install the Extension Pack: https://download.virtualbox.org/virt...8.vbox-extpack
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  4. #4
    Join Date
    Apr 2006
    Beans
    2,673

    Re: Unable to upgrade VirtualBox

    Quote Originally Posted by SeijiSensei View Post
    Follow the procedure described here

    https://www.virtualbox.org/wiki/Linu...xdistributions

    to add Oracle's repository to your system. Next remove your current virtualbox installation with

    Code:
    sudo apt purge virtualbox
    then install VB 6.1 with

    Code:
    sudo apt update
    sudo apt install virtualbox-6.1
    Your system will upgrade VB automatically when needed just like it updates software in the Ubuntu repositories.

    After you've finished and VB works as expected, install the Extension Pack: https://download.virtualbox.org/virt...8.vbox-extpack
    Hi,

    Thanks for your advice.

    Performed following steps:-

    $ sudo nano /etc/apt/sources.list
    That line is already there but being commented out.
    Un-comment that line

    Reboot PC

    $ sudo apt purge virtualbox
    Code:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package 'virtualbox' is not installed, so not removed
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Very strange to me? Virtual Box is running on this PC

    $ sudo dpkg -l | grep virtualbox
    Code:
    ii  virtualbox-6.0                             6.0.22-137980~Ubuntu~bionic                      amd64        Oracle VM VirtualBox
    Is it a test-built version? How to remove it? Thanks

    Regards
    satimis

  5. #5
    Join Date
    Apr 2006
    Beans
    2,673

    Re: Unable to upgrade VirtualBox

    Quote Originally Posted by halogen2 View Post
    What version of VirtualBox are you trying to upgrade to?
    Does it work for you to manually download the new version from the official website, apt-get purge the existing VirtualBox, then install the new version?
    Thanks for your advice.

    Running version 6.0
    Upgrade it to version 6.1

    Please see my reply to SeijiSensei's above. Tks

    Regards
    satimis

  6. #6
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Unable to upgrade VirtualBox

    You will need to run sudo apt purge virtualbox-6.0 to remove the version you already have.

    Or simply run sudo apt install virtualbox-6.1 (assuming you really do have the VBox repos enabled as you say) and it will remove version 6.o and install 6.1 in its place.

    Ypou might find using synaptic gives you a much clearer view of what you already have installed and what will happen when you try to add version 6.1.
    DISTRO: Xubuntu 20.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  7. #7
    Join Date
    Apr 2006
    Beans
    2,673

    Re: Unable to upgrade VirtualBox

    Quote Originally Posted by ajgreeny View Post
    You will need to run sudo apt purge virtualbox-6.0 to remove the version you already have.

    Or simply run sudo apt install virtualbox-6.1 (assuming you really do have the VBox repos enabled as you say) and it will remove version 6.o and install 6.1 in its place.

    Ypou might find using synaptic gives you a much clearer view of what you already have installed and what will happen when you try to add version 6.1.
    Hi,

    Thanks for your advice.

    Performed following steps
    - install synatic package manager
    - start synatic package manager

    On search, found virtualbox 6.1

    Please see attached file "screenshot_synaptic.png"

    What will be next step?
    Do I need to select "volatility?

    Whether following tutorial is applicable ?

    SynapticHowto
    https://help.ubuntu.com/community/SynapticHowto

    Thanks

    Regards
    satimis
    Attached Images Attached Images

  8. #8
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    15,055
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: Unable to upgrade VirtualBox

    The package virtualbox-6.0 must have come from Oracle's website. The packages there have a version number attached to distinguish them from the version in the repositories which is always called just "virtualbox."

    I rarely muck around with GUI package managers. I much prefer using the command line.
    Code:
    sudo apt update
    sudo apt install virtualbox-6.1
    When you run "update" you should see the Oracle repository in the list.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  9. #9
    Join Date
    Apr 2006
    Beans
    2,673

    Re: Unable to upgrade VirtualBox

    Quote Originally Posted by SeijiSensei View Post
    The package virtualbox-6.0 must have come from Oracle's website. The packages there have a version number attached to distinguish them from the version in the repositories which is always called just "virtualbox."

    I rarely muck around with GUI package managers. I much prefer using the command line.
    Code:
    sudo apt update
    sudo apt install virtualbox-6.1
    When you run "update" you should see the Oracle repository in the list.
    Agreed, I usually install and/or upgrade packages on Terminal, running command lines.

    This is my 1st time running synaptic to install/upgrade package. It is just for interest as well as for learning this software.

    $ sudo apt update | grep virtualbox
    Code:
    WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
    
    Hit:8 https://download.virtualbox.org/virtualbox/debian bionic InRelease
    Regards

  10. #10
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Unable to upgrade VirtualBox

    The main reason I suggested using synaptic was because it gives you a clearer idea of all the package versions for virtualbox that are available, and allows you to see where they're from if you use the Origin filter in the left pane.

    I'm not running bionic now and can't remember but I think the bionic repos from Oracle have both versions 6.0 and 6.1; Ubuntu's own repos had version 5 only if I remember correctly.
    Focal now has versions 6.0 and 6.1 in its own repos and both are also from the Oracle repos, but the Oracle repo version is slightly ahead of the Ubuntu version and I have always found it to work better particularly when using the guest additions package also direct from Oracle.

    I have no idea what that volatility package is or what it has to do with virtualbox. Did it show up when you searched for virtualbox in synaptic?
    It is not even in the repos for focal so I've no idea what it is or what it does, but I do not think you need to install it.
    Last edited by ajgreeny; May 22nd, 2020 at 10:13 PM.
    DISTRO: Xubuntu 20.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •