Just happened to notice snapd was not installed and did not know how since it is a dependency of chromium-browser which is installed
Code:
chromium-browser:
  Installed: 81.0.4044.122-0ubuntu0.18.04.1
  Candidate: 81.0.4044.122-0ubuntu0.18.04.1
  Version table:
 *** 81.0.4044.122-0ubuntu0.18.04.1 100
        100 /var/lib/dpkg/status
     80.0.3987.163-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu focal/universe amd64 Packages