View Poll Results: Share with us your Upgrade/Installation Experience

Voters
21. You may not vote on this poll
  • Upgrade - Worked Flawlessly.

    6 28.57%
  • Upgrade - Worked but had a few things to fix, nothing serious though..

    2 9.52%
  • Upgrade - Had many problems that I've not been able to solve.

    0 0%
  • Install - Worked flawlessly.

    8 38.10%
  • Install - Worked but had a few things to fix.

    5 23.81%
  • Install - Had many problems that I have not been able to solve.

    0 0%
Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: Share with us your Focal installation/Upgrade Experience

  1. #21
    Join Date
    May 2020
    Location
    Earthrealm
    Beans
    14
    Distro
    Ubuntu 20.04 Focal Fossa

    Red face Re: Share with us your Focal installation/Upgrade Experience

    Quote Originally Posted by sudodus View Post
    Please tell us which tool you used to make the live drive, when you had the problem 'gfxboot.c32: not a COM32R image'. It looks like an old problem, that affected some extracting tools (it was squashed in the Ubuntu Startup Disk Creator version bundled with Ubuntu 16.04 LTS). Has it popped up again in Unetbootin? or some other tool?
    @sudodus

    I followed this tutorial when creating my LiveCD/USB stick with Ubuntu Startup Disk Creator using an old Lubuntu install based on Ubuntu 14.something LTS I think.
    https://ubuntu.com/tutorials/tutoria...ntu#1-overview



    • My Windows gaming machine couldn't detect my USB stick which I previously had tried and failed to install Qubes OS with (recommended by Edward Snowden). Which also meant that my Ubuntu guest VMs on VirtualBox couldn't detect and write to that USB stick.
      .
    • Also I didn't want to risk my Windows gaming machine messing with partitions.
      .


    The only working machine I had at home at that time which could detect and repair that Qubes OS LiveCD/USB stick was with my old trusty Lubuntu.

    How to Repair a Corrupted USB drive in Linux
    https://www.maketecheasier.com/repai...b-drive-linux/
    Last edited by mortalkorona; 2 Weeks Ago at 09:47 AM. Reason: Signature?

  2. #22
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: Share with us your Focal installation/Upgrade Experience

    It's been a mixed bag.

    As expected, the virgin installs gave me the least problems, though they were not entirely trouble-free either. Servers, whether upgrades or new installs, went without any hitches; desktops were a different story:

    1. My older AMD GPU will only run the Radeon driver. Noticeably more lag and choppy graphics than with Bionic. Surprising and disappointing.
    2. Irritating defaults like pulseaudio ignoring last setting and always defaulting to USB,
    3. Bug in Totem or associated library makes videos so choppy as to be unplayable. Using VLC as workaround. It works nicely.
    4. 4K video no longer 60Hz. Only 30Hz offered by default. No doubt these are limitations unique to my GPU/Monitor/cabling/EDID config, but still disappointing given that I could run 60Hz in Bionic. Partially worked around by creating custom ~/.xprofile but this causes periodic screen tearing and shifting (no such problems in Bionic).
    5. Both pluses and minuses in app changes: GIMP is finally a coordinated app instead of silly separate windows, LibreOffice has bugs, GnuCash has changed its default config location, Rhythmbox has nerfed UI that does not allow importing tracks, etc.
    6. Focal notably boots faster than Bionic
    7. Allows ZFS root installs natively which is pretty cool.

    The upgrades were more problematic. Unfortunately, a lot more. To set the stage, prior to upgrading, I tried to back out as many customizations as I could remember. The system was as close to a default state as 2+ years of power usage would allow.

    1. Pulseaudio problems. All output redirected to one audio sink. Finally solved by nuking ~/.config/pulse and rebuilding one from scratch.
    2. KVM problems. All inherited VMs hung at shutdown necessitating being killed, then destroyed. Finally solved by purging and reinstalling the whole virt-manager stack. This then broke custom seabios resolutions.
    3. Some VMs have migrated well, others not so well.
    4. Scanner and printing either acted oddly or stopped working altogether. Solved by purging old printers and reinstalling from scratch.
    5. Some apps came out well, others, not so well, still others, very poorly. Wonky post-upgrade behaviour from a number of apps including LibreOffice, Signal, Rhythmbox.
    6. LXD containers migrated nicely, which is pleasantly surprising. Was expecting more problems.

    Altogether, neither more nor less problematic than past upgrades. The first point release should fix many of the worst bugs; fewer of the non-critical but still irritating ones.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •