Results 1 to 3 of 3

Thread: Can't use serial connection

  1. #1
    Join Date
    Apr 2020
    Beans
    1

    Can't use serial connection

    Anybody know how to stop agetty from hording ttyS0?

    I have a Raspberry Pi hat that uses serial via the GPIO. However, I can't connect gpsd to ttyS0. And if I'm able to successfully minicom in to S0 it acts that like it's refreshing at a berserk level and I occasionally see something that looks like a "Login:" prompt.

  2. #2
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    1,035
    Distro
    Xubuntu

    Re: Can't use serial connection

    Wow! It it is my guess that not many forum participants have all of these devices.
    A Raspberry Pi. Which model?
    A Pi Hat. I have one of those - not a GPS Hat though.
    GPSD. Do you also have a GPS device? I have one of those - Prolific PL2303
    Minicom. Don't know anything about that. Found this on the minicom website 'minicom is a serial communication program that connects to devices through a GNU/Linux PC's serial ports.'

    Which verson of *buntu?

    Added: Found this page related to minicom, https://help.ubuntu.com/community/Minicom

    Please provide some more information about your setup - both hardware and software. Need to be patient though, it has been a few years since I worked with any GPS applications.

    If I can duplicate your setup, maybe we can figure something out.
    Last edited by him610; April 21st, 2020 at 11:33 PM. Reason: To post additional info
    Cheers,


    The Linux Command Line at http://linuxcommand.org/

  3. #3
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Can't use serial connection

    Quote Originally Posted by boydhako View Post
    Anybody know how to stop agetty from hording ttyS0?
    Yes a lot of information needed to inform you with a better experience.
    **Please follow him610 advice first, and use my post as a last resort.
    But what I see and guess is, You can probably shut down the getty process on /dev/ttyS0, as it does not seem to be doing anything useful right now. To do that, these commands might be the simplest solution:
    Code:
    systemctl stop serial-getty@ttyS0.service
    systemctl disable serial-getty@ttyS0.service
    The first command tells systemd to stop trying to start the process until the next reboot, the second command will persistently mark it as disabled.
    you should also check your boot options: if console=ttyS0 is listed in there, systemd will automatically generate a getty process on /dev/ttyS0. **Note: This is for Ubuntu on a PI4 and not tested with Raspbian.
    Last edited by 1fallen; April 21st, 2020 at 11:40 PM. Reason: added to
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •