Results 1 to 4 of 4

Thread: VMware - The guest operating system has locked the CD-ROM

  1. #1
    Join Date
    Apr 2020
    Beans
    2

    VMware - The guest operating system has locked the CD-ROM

    I've been struggling with the following problem.

    I need to install vmware tool in a virtual xubuntu OS, and it's not letting me do that. I'd appreciate if anyone here could help me with this.

    The guest operating system has locked the CD-ROM door and is probably using the CD-ROM, which can prevent the guest from recognizing media changes. If possible, eject the CD-ROM from inside the guest before disconnecting.

    Disconnect anyway and override the lock?
    Thanks.

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    21,382
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: VMware - The guest operating system has locked the CD-ROM

    Have you tried ejecting the virtual optical disk? Use the umount command, if needed. It is possible the install ISO is still connected to the VM in the VM settings. Check that too.

  3. #3
    Join Date
    Apr 2020
    Beans
    2

    Re: VMware - The guest operating system has locked the CD-ROM

    I don't see any virtual disk connected. And the ISO which I used to install the OS, I've changed that ISO to the physical CD-ROM. So, it's not mounted as well.

  4. #4
    Join Date
    Nov 2016
    Beans
    2

    Re: VMware - The guest operating system has locked the CD-ROM

    Quote Originally Posted by mubeenkh View Post
    I've been struggling with the following problem.

    I need to install vmware tool in a virtual xubuntu OS, and it's not letting me do that. I'd appreciate if anyone here could help me with this.



    Thanks.
    Hi mubeenkh,

    It should always be locked because it is a CDROM. Just copy the content to your hard drive and execute from there.

    jn

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •