Ok, I fixed it.
Reinstalled it, and using gparted i switched the sdb table to gpt and created a partition that is "boot", "esp". and with the "something else" option chose to install it directly in sdb.


I guess technically both solution worked, but at the start the installation itself was bugged or something to not show the desktop environment properly.