Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: .DEB Files No Longer Supported by 20.04!?!?

  1. #1
    Join Date
    Apr 2018
    Location
    Novelty, Ohio
    Beans
    82
    Distro
    Ubuntu

    Angry .DEB Files No Longer Supported by 20.04!?!?

    Did Canonical make 20.04 no longer support .deb files or will they be supported again once it's officially released?

  2. #2
    Join Date
    Apr 2007
    Location
    NH USA
    Beans
    1,459
    Distro
    Ubuntu Development Release

    Re: .DEB Files No Longer Supported by 20.04!?!?

    What are you talking about? They are moving some apps over to snap, but the deb/dpkg/apt system accounts for practically all of the system. What have you encountered that makes you think that deb is no longer supported?

  3. #3
    Join Date
    Apr 2018
    Location
    Novelty, Ohio
    Beans
    82
    Distro
    Ubuntu

    Re: .DEB Files No Longer Supported by 20.04!?!?

    I tried to install a .deb file and the snap store said "Not Supported".

  4. #4
    Join Date
    Aug 2017
    Location
    melbourne, au
    Beans
    500
    Distro
    Lubuntu Development Release

    Re: .DEB Files No Longer Supported by 20.04!?!?

    I have noticed no changes on this box (bumped to focal Oct-2019) nor on any QA-test installs of focal either, though I tend to use package managers or more commonly terminal to install packages.

  5. #5
    Join Date
    Oct 2009
    Beans
    485
    Distro
    Ubuntu Development Release

    Re: .DEB Files No Longer Supported by 20.04!?!?

    snap store don't support installation of .deb files for example google-chrome. You have to use software, but software isn't installed as default and you have to install it.

  6. #6
    Join Date
    Jun 2007
    Beans
    17,304

    Re: .DEB Files No Longer Supported by 20.04!?!?

    Quote Originally Posted by bionic3epl View Post
    I tried to install a .deb file and the snap store said "Not Supported".
    If you have a .deb that you downloaded then
    Code:
    sudo apt install /path/to/whatever.deb
    If you want a package manager that only list.deb packages install & use synaptic
    Last edited by mc4man; April 3rd, 2020 at 08:58 AM. Reason: cell phone nonsense

  7. #7
    Join Date
    Apr 2018
    Location
    Novelty, Ohio
    Beans
    82
    Distro
    Ubuntu

    Re: .DEB Files No Longer Supported by 20.04!?!?

    Synaptic won't show in snap store nor a package manager will show in snap store in 20.04. Could that be because it's still in beta?

  8. #8
    Join Date
    Apr 2018
    Location
    Novelty, Ohio
    Beans
    82
    Distro
    Ubuntu

    Re: .DEB Files No Longer Supported by 20.04!?!?

    I just tried that term command & it says "Unsupported File". Could that all because it's still in beta stage?

  9. #9
    Join Date
    Oct 2008
    Location
    Rezzoaglio (GE) Italy
    Beans
    331
    Distro
    Ubuntu Development Release

    Re: .DEB Files No Longer Supported by 20.04!?!?

    In Ubuntu 20.04 new app named 'Ubuntu software' is really snap-store. Snap-store does not support .deb files (I hope is just a bug)
    For .deb files You need gnome-software (old Ubuntu Software) or synaptic.
    You can install with 'sudo apt install synaptic' and 'sudo apt install gnome-software'

    Edit: In the attachment 'Software' is gnome-software and 'Ubuntu Software' is snap-store with same icon! to make fun of users!
    Attached Images Attached Images
    Last edited by corradoventu; April 3rd, 2020 at 04:23 PM. Reason: added attachment

  10. #10
    Join Date
    Oct 2009
    Beans
    485
    Distro
    Ubuntu Development Release

    Re: .DEB Files No Longer Supported by 20.04!?!?

    @corradoventu, earlier today the icons were different, but as you write they are the same now "Ubuntu Software" = "Snap Store" and Software the usable version is "gnome-software". Perhaps everybody need to post in this thread https://discourse.ubuntu.com/t/is-ub...ap-store/14542 to make Canonical to withdraw the decision to use "Snap Store" in Ubuntu 20.04.

    Perhaps it's not needed, checked now and Ubuntu Software behaves much better. Both Tweaks and Synaptics are available,
    Last edited by P-I H; April 3rd, 2020 at 05:49 PM.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •