Results 1 to 3 of 3

Thread: AC1200 Driver on new install - Drivers working but can't hold connection

  1. #1
    Join Date
    Mar 2020
    Beans
    1

    Lightbulb AC1200 Driver on new install - Drivers working but can't hold connection

    Hey all,

    I recently installed Ubuntu and managed to install the drivers for my WiFi adapter (Supola AC1200 USB 3.0 Dual Band) by researching previous threads - using the driver provided here.
    https://github.com/cilynx/rtl88x2bu

    However, now that I've installed the driver I am having constant issues with maintaining my WiFi connection. It rarely notices my 5GHz signal (only finding the 2.5GHz one) and It's a constant challenge to keep it connected. I am constantly fighting with it to make it connect to the signal - it sees it clearly and it works fine on all other devices in my house. It just keeps trying to connect - and gives up most of the time. When it does connect - it stays connected for a few minutes - before droppping out and returning to the vicious cycle of trying to connect over and over. Previously when I used Windows 10, I had no issues with my wireless adapter. I had a strong signal to my 5GHz signal, and never experienced any dropouts.

    Could this be a driver issue? Is there someway to fix this? I'm losing my mind browsing different threads desperately trying to find a solution.

    Thanks,

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,131
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: AC1200 Driver on new install - Drivers working but can't hold connection

    Have you tried all the usual tips and tricks?

    First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

    Then set your regulatory domain explicitly. Check yours:
    Code:
    sudo iw reg get
    If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:
    Code:
    sudo iw reg set IS
    Of course, substitute your country code if not Iceland. Set it permanently:
    Code:
    sudo nano /etc/default/crda
    Change the last line to read:
    Code:
    REGDOMAIN=IS
    Proofread carefully, save (Ctrl+o followed by Enter) and close (Ctrl+x) the text editor.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  3. #3
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    7,817
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: AC1200 Driver on new install - Drivers working but can't hold connection

    Hi Chili,

    this doesn't work as it is not an full-MAC driver, only supporting the cfg80211 subsystem

    Code:
    echo 'options 88x2bu rtw_country_code="IS"' | sudo tee /etc/modprobe.d/88x2bu_options.conf
    and rebooting should do that trick. Maybe also this one

    Code:
    sudo sed -i "s/wifi.powersave = 3/wifi.powersave = 2/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
    sudo systemctl restart network-manager.service

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •