Support for 14.04.x ended about a year ago. Move to 16.04 or better, 18.04.
Yes, indeed! We are fairly confident that if you run a live version of 18.04 LTS, your ethernet will work immediately. If it does, then we recommend that you install it.

@TheFu Thank you for your very kind words.