Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 60

Thread: no wireless for my laptop

  1. #21
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,131
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: no wireless for my laptop

    and what about the reltek 8821ce drivers i need to install?
    i guess that is next after that
    Please see my post #2 where I gave you the link which includes instructions.

    am i to download bcmwl-kernal source? that is for broadcom wireless, and i have realtek 8821ce chipset
    My instructions above clearly say, "...with the exception of bcmwl-kernel-source," so no.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  2. #22
    Join Date
    Mar 2020
    Beans
    41

    Re: no wireless for my laptop

    ok ...all files copied...going over to ubuntu to try....brb

  3. #23
    Join Date
    Mar 2020
    Beans
    41

    Re: no wireless for my laptop

    ok back....no good... a lot of errors... dependency problems - leaving unconfigured


    Setting up libc6-dev:amd64 (2.27-3ubuntu1) ...
    Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
    Processing triggers for libc-bin (2.27-3ubuntu1) ...
    Errors were encountered while processing:
    dpkg-dev
    g++-7
    gcc-7
    libasan4:amd64
    libatomic1:amd64
    libcilkrts5:amd64
    libgcc-7-dev:amd64
    libitm1:amd64
    liblsan0:amd64
    libmpx2:amd64
    libquadmath0:amd64
    libstdc++-7-dev:amd64
    libtsan0:amd64
    libubsan0:amd64
    build-essential
    dkms
    g++
    gcc


    and then this...



    dominic@dominic-HP-Laptop-15-db1xxx:~/Downloads/rtl8821ce$ dir
    clean hal ifcfg-wlan0 Kconfig os_dep rtl8821c.mk wlan0dhcp
    core halmac.mk include Makefile platform runwpa
    dominic@dominic-HP-Laptop-15-db1xxx:~/Downloads/rtl8821ce$ make clean
    /bin/sh: 1: cc: not found
    (standard_in) 1: syntax error
    #make -C /lib/modules/5.3.0-28-generic/build M=/home/dominic/Downloads/rtl8821ce clean
    cd hal ; rm -fr */*/*/*.mod.c */*/*/*.mod */*/*/*.o */*/*/.*.cmd */*/*/*.ko
    cd hal ; rm -fr */*/*.mod.c */*/*.mod */*/*.o */*/.*.cmd */*/*.ko
    cd hal ; rm -fr */*.mod.c */*.mod */*.o */.*.cmd */*.ko
    cd hal ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
    cd core ; rm -fr */*.mod.c */*.mod */*.o */.*.cmd */*.ko
    cd core ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
    cd os_dep/linux ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
    cd os_dep ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
    cd platform ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
    rm -fr Module.symvers ; rm -fr Module.markers ; rm -fr modules.order
    rm -fr *.mod.c *.mod *.o .*.cmd *.ko *~
    rm -fr .tmp_versions
    dominic@dominic-HP-Laptop-15-db1xxx:~/Downloads/rtl8821ce$ make
    /bin/sh: 1: cc: not found
    (standard_in) 1: syntax error
    make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.3.0-28-generic/build M=/home/dominic/Downloads/rtl8821ce modules
    make[1]: Entering directory '/usr/src/linux-headers-5.3.0-28-generic'
    /home/dominic/Downloads/rtl8821ce/Makefile:2157: home/dominic/Downloads/rtl8821ce/hal/phydm/phydm.mk: No such file or directory
    /home/dominic/Downloads/rtl8821ce/Makefile:2166: home/dominic/Downloads/rtl8821ce/rtl8821c.mk: No such file or directory
    make[2]: *** No rule to make target 'home/dominic/Downloads/rtl8821ce/rtl8821c.mk'. Stop.
    Makefile:1655: recipe for target '_module_/home/dominic/Downloads/rtl8821ce' failed
    make[1]: *** [_module_/home/dominic/Downloads/rtl8821ce] Error 2
    make[1]: Leaving directory '/usr/src/linux-headers-5.3.0-28-generic'
    Makefile:2237: recipe for target 'modules' failed
    make: *** [modules] Error 2
    dominic@dominic-HP-Laptop-15-db1xxx:~/Downloads/rtl8821ce$ sudo make install
    /bin/sh: 1: cc: not found
    (standard_in) 1: syntax error
    install -p -m 644 8821ce.ko /lib/modules/5.3.0-28-generic/kernel/drivers/net/wireless/
    install: cannot stat '8821ce.ko': No such file or directory
    Makefile:2243: recipe for target 'install' failed
    make: *** [install] Error 1
    dominic@dominic-HP-Laptop-15-db1xxx:~/Downloads/rtl8821ce$ sudo modprobe 8821ce
    modprobe: FATAL: Module 8821ce not found in directory /lib/modules/5.3.0-28-generic
    dominic@dominic-HP-Laptop-15-db1xxx:~/Downloads/rtl8821ce$

    did i mess it up worse?
    help
    Last edited by kickass1955; 2 Weeks Ago at 02:22 AM.

  4. #24
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,131
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: no wireless for my laptop

    Try to install the packages that ended in errors one at a time and let’s see exactly what the error is, for example:

    sudo dpkg -i dpkg-dev*.deb

    And so on.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  5. #25
    Join Date
    Mar 2020
    Beans
    41

    Re: no wireless for my laptop

    ok ... will make a list of ones bad....brb

  6. #26
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,131
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: no wireless for my laptop

    Quote Originally Posted by kickass1955 View Post
    ok ... will make a list of ones bad....brb
    We need to see the exact error.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  7. #27
    Join Date
    Mar 2020
    Beans
    41

    Re: no wireless for my laptop

    here is whole list....sorry for it is long

    Code:
    dominic@dominic-HP-Laptop-15-db1xxx:~/Desktop/debs$ sudo dpkg -i *.deb
      (Reading database ... 132444 files and directories currently installed.)
      Preparing to unpack build-essential_12.4ubuntu1_amd64.deb ...
      Unpacking build-essential (12.4ubuntu1) over (12.4ubuntu1) ...
      Preparing to unpack dkms_2.3-3ubuntu9_all.deb ...
      Unpacking dkms (2.3-3ubuntu9) over (2.3-3ubuntu9) ...
      Preparing to unpack dpkg-dev_1.19.0.5ubuntu2_all.deb ...
      Unpacking dpkg-dev (1.19.0.5ubuntu2) over (1.19.0.5ubuntu2) ...
      Preparing to unpack fakeroot_1.22-2ubuntu1_amd64.deb ...
      Unpacking fakeroot (1.22-2ubuntu1) over (1.22-2ubuntu1) ...
      Preparing to unpack g++_7.4.0-1ubuntu2.3_amd64.deb ...
      Unpacking g++ (4:7.4.0-1ubuntu2.3) over (4:7.4.0-1ubuntu2.3) ...
      Preparing to unpack g++-7_7.5.0-3ubuntu1~18.04_amd64.deb ...
      Unpacking g++-7 (7.5.0-3ubuntu1~18.04) over (7.5.0-3ubuntu1~18.04) ...
      Preparing to unpack gcc_7.4.0-1ubuntu2.3_amd64.deb ...
      Unpacking gcc (4:7.4.0-1ubuntu2.3) over (4:7.4.0-1ubuntu2.3) ...
      Preparing to unpack gcc-7_7.5.0-3ubuntu1~18.04_amd64.deb ...
      Unpacking gcc-7 (7.5.0-3ubuntu1~18.04) over (7.5.0-3ubuntu1~18.04) ...
      Preparing to unpack libalgorithm-diff-perl_1.19.03-1_all.deb ...
      Unpacking libalgorithm-diff-perl (1.19.03-1) over (1.19.03-1) ...
      Preparing to unpack libalgorithm-diff-xs-perl_0.04-5_amd64.deb ...
      Unpacking libalgorithm-diff-xs-perl (0.04-5) over (0.04-5) ...
      Preparing to unpack libalgorithm-merge-perl_0.08-3_all.deb ...
      Unpacking libalgorithm-merge-perl (0.08-3) over (0.08-3) ...
      Preparing to unpack libasan4_7.5.0-3ubuntu1~18.04_amd64.deb ...
      Unpacking libasan4:amd64 (7.5.0-3ubuntu1~18.04) over (7.5.0-3ubuntu1~18.04) ...
      Preparing to unpack libatomic1_8.3.0-26ubuntu1~18.04_amd64.deb ...
      Unpacking libatomic1:amd64 (8.3.0-26ubuntu1~18.04) over (8.3.0-26ubuntu1~18.04) ...
      Preparing to unpack libc6-dev_2.27-3ubuntu1_amd64.deb ...
      Unpacking libc6-dev:amd64 (2.27-3ubuntu1) over (2.27-3ubuntu1) ...
      Preparing to unpack libc-dev-bin_2.27-3ubuntu1_amd64.deb ...
      Unpacking libc-dev-bin (2.27-3ubuntu1) over (2.27-3ubuntu1) ...
      Preparing to unpack libcilkrts5_7.5.0-3ubuntu1~18.04_amd64.deb ...
      Unpacking libcilkrts5:amd64 (7.5.0-3ubuntu1~18.04) over (7.5.0-3ubuntu1~18.04) ...
      Preparing to unpack libfakeroot_1.22-2ubuntu1_amd64.deb ...
      Unpacking libfakeroot:amd64 (1.22-2ubuntu1) over (1.22-2ubuntu1) ...
      Preparing to unpack libgcc-7-dev_7.5.0-3ubuntu1~18.04_amd64.deb ...
      Unpacking libgcc-7-dev:amd64 (7.5.0-3ubuntu1~18.04) over (7.5.0-3ubuntu1~18.04) ...
      Preparing to unpack libitm1_8.3.0-26ubuntu1~18.04_amd64.deb ...
      Unpacking libitm1:amd64 (8.3.0-26ubuntu1~18.04) over (8.3.0-26ubuntu1~18.04) ...
      Preparing to unpack liblsan0_8.3.0-26ubuntu1~18.04_amd64.deb ...
      Unpacking liblsan0:amd64 (8.3.0-26ubuntu1~18.04) over (8.3.0-26ubuntu1~18.04) ...
      Preparing to unpack libmpx2_8.3.0-26ubuntu1~18.04_amd64.deb ...
      Unpacking libmpx2:amd64 (8.3.0-26ubuntu1~18.04) over (8.3.0-26ubuntu1~18.04) ...
      Preparing to unpack libquadmath0_8.3.0-26ubuntu1~18.04_amd64.deb ...
      Unpacking libquadmath0:amd64 (8.3.0-26ubuntu1~18.04) over (8.3.0-26ubuntu1~18.04) ...
      Preparing to unpack libstdc++-7-dev_7.5.0-3ubuntu1~18.04_amd64.deb ...
      Unpacking libstdc++-7-dev:amd64 (7.5.0-3ubuntu1~18.04) over (7.5.0-3ubuntu1~18.04) ...
      Preparing to unpack libtsan0_8.3.0-26ubuntu1~18.04_amd64.deb ...
      Unpacking libtsan0:amd64 (8.3.0-26ubuntu1~18.04) over (8.3.0-26ubuntu1~18.04) ...
      Preparing to unpack libubsan0_7.5.0-3ubuntu1~18.04_amd64.deb ...
      Unpacking libubsan0:amd64 (7.5.0-3ubuntu1~18.04) over (7.5.0-3ubuntu1~18.04) ...
      Preparing to unpack linux-libc-dev_4.15.0-91.92_amd64.deb ...
      Unpacking linux-libc-dev:amd64 (4.15.0-91.92) over (4.15.0-91.92) ...
      Preparing to unpack make_4.1-9.1ubuntu1_amd64.deb ...
      Unpacking make (4.1-9.1ubuntu1) over (4.1-9.1ubuntu1) ...
      Preparing to unpack manpages-dev_4.15-1_all.deb ...
      Unpacking manpages-dev (4.15-1) over (4.15-1) ...
      dpkg: dependency problems prevent configuration of dpkg-dev:
       dpkg-dev depends on libdpkg-perl (= 1.19.0.5ubuntu2); however:
        Version of libdpkg-perl on system is 1.19.0.5ubuntu2.3.
       
      dpkg: error processing package dpkg-dev (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of g++-7:
       g++-7 depends on gcc-7-base (= 7.5.0-3ubuntu1~18.04); however:
        Version of gcc-7-base:amd64 on system is 7.4.0-1ubuntu1~18.04.1.
       
      dpkg: error processing package g++-7 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of gcc-7:
       gcc-7 depends on cpp-7 (= 7.5.0-3ubuntu1~18.04); however:
        Version of cpp-7 on system is 7.4.0-1ubuntu1~18.04.1.
       gcc-7 depends on gcc-7-base (= 7.5.0-3ubuntu1~18.04); however:
        Version of gcc-7-base:amd64 on system is 7.4.0-1ubuntu1~18.04.1.
       
      dpkg: error processing package gcc-7 (--install):
       dependency problems - leaving unconfigured
      Setting up libalgorithm-diff-perl (1.19.03-1) ...
      Setting up libalgorithm-diff-xs-perl (0.04-5) ...
      Setting up libalgorithm-merge-perl (0.08-3) ...
      dpkg: dependency problems prevent configuration of libasan4:amd64:
       libasan4:amd64 depends on gcc-7-base (= 7.5.0-3ubuntu1~18.04); however:
        Version of gcc-7-base:amd64 on system is 7.4.0-1ubuntu1~18.04.1.
       
      dpkg: error processing package libasan4:amd64 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of libatomic1:amd64:
       libatomic1:amd64 depends on gcc-8-base (= 8.3.0-26ubuntu1~18.04); however:
        Version of gcc-8-base:amd64 on system is 8.3.0-6ubuntu1~18.04.1.
       
      dpkg: error processing package libatomic1:amd64 (--install):
       dependency problems - leaving unconfigured
      Setting up libc-dev-bin (2.27-3ubuntu1) ...
      dpkg: dependency problems prevent configuration of libcilkrts5:amd64:
       libcilkrts5:amd64 depends on gcc-7-base (= 7.5.0-3ubuntu1~18.04); however:
        Version of gcc-7-base:amd64 on system is 7.4.0-1ubuntu1~18.04.1.
       
      dpkg: error processing package libcilkrts5:amd64 (--install):
       dependency problems - leaving unconfigured
      Setting up libfakeroot:amd64 (1.22-2ubuntu1) ...
      dpkg: dependency problems prevent configuration of libgcc-7-dev:amd64:
       libgcc-7-dev:amd64 depends on gcc-7-base (= 7.5.0-3ubuntu1~18.04); however:
        Version of gcc-7-base:amd64 on system is 7.4.0-1ubuntu1~18.04.1.
       libgcc-7-dev:amd64 depends on libatomic1 (>= 7.5.0-3ubuntu1~18.04); however:
        Package libatomic1:amd64 is not configured yet.
       libgcc-7-dev:amd64 depends on libasan4 (>= 7.5.0-3ubuntu1~18.04); however:
        Package libasan4:amd64 is not configured yet.
       libgcc-7-dev:amd64 depends on libcilkrts5 (>= 7.5.0-3ubuntu1~18.04); however:
        Package libcilkrts5:amd64 is not configured yet.
       
      dpkg: error processing package libgcc-7-dev:amd64 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of libitm1:amd64:
       libitm1:amd64 depends on gcc-8-base (= 8.3.0-26ubuntu1~18.04); however:
        Version of gcc-8-base:amd64 on system is 8.3.0-6ubuntu1~18.04.1.
       
      dpkg: error processing package libitm1:amd64 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of liblsan0:amd64:
       liblsan0:amd64 depends on gcc-8-base (= 8.3.0-26ubuntu1~18.04); however:
        Version of gcc-8-base:amd64 on system is 8.3.0-6ubuntu1~18.04.1.
       
      dpkg: error processing package liblsan0:amd64 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of libmpx2:amd64:
       libmpx2:amd64 depends on gcc-8-base (= 8.3.0-26ubuntu1~18.04); however:
        Version of gcc-8-base:amd64 on system is 8.3.0-6ubuntu1~18.04.1.
       
      dpkg: error processing package libmpx2:amd64 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of libquadmath0:amd64:
       libquadmath0:amd64 depends on gcc-8-base (= 8.3.0-26ubuntu1~18.04); however:
        Version of gcc-8-base:amd64 on system is 8.3.0-6ubuntu1~18.04.1.
       
      dpkg: error processing package libquadmath0:amd64 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of libstdc++-7-dev:amd64:
       libstdc++-7-dev:amd64 depends on gcc-7-base (= 7.5.0-3ubuntu1~18.04); however:
        Version of gcc-7-base:amd64 on system is 7.4.0-1ubuntu1~18.04.1.
       libstdc++-7-dev:amd64 depends on libgcc-7-dev (= 7.5.0-3ubuntu1~18.04); however:
        Package libgcc-7-dev:amd64 is not configured yet.
       
      dpkg: error processing package libstdc++-7-dev:amd64 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of libtsan0:amd64:
       libtsan0:amd64 depends on gcc-8-base (= 8.3.0-26ubuntu1~18.04); however:
        Version of gcc-8-base:amd64 on system is 8.3.0-6ubuntu1~18.04.1.
       
      dpkg: error processing package libtsan0:amd64 (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of libubsan0:amd64:
       libubsan0:amd64 depends on gcc-7-base (= 7.5.0-3ubuntu1~18.04); however:
        Version of gcc-7-base:amd64 on system is 7.4.0-1ubuntu1~18.04.1.
       
      dpkg: error processing package libubsan0:amd64 (--install):
       dependency problems - leaving unconfigured
      Setting up linux-libc-dev:amd64 (4.15.0-91.92) ...
      Setting up make (4.1-9.1ubuntu1) ...
      Setting up manpages-dev (4.15-1) ...
      dpkg: dependency problems prevent configuration of build-essential:
       build-essential depends on dpkg-dev (>= 1.17.11); however:
        Package dpkg-dev is not configured yet.
       
      dpkg: error processing package build-essential (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of dkms:
       dkms depends on dpkg-dev; however:
        Package dpkg-dev is not configured yet.
       
      dpkg: error processing package dkms (--install):
       dependency problems - leaving unconfigured
      Setting up fakeroot (1.22-2ubuntu1) ...
      dpkg: dependency problems prevent configuration of g++:
       g++ depends on g++-7 (>= 7.4.0-1~); however:
        Package g++-7 is not configured yet.
       g++ depends on gcc-7 (>= 7.4.0-1~); however:
        Package gcc-7 is not configured yet.
       
      dpkg: error processing package g++ (--install):
       dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of gcc:
       gcc depends on gcc-7 (>= 7.4.0-1~); however:
        Package gcc-7 is not configured yet.
       
      dpkg: error processing package gcc (--install):
       dependency problems - leaving unconfigured
      Setting up libc6-dev:amd64 (2.27-3ubuntu1) ...
      Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
      Processing triggers for libc-bin (2.27-3ubuntu1) ...
      Errors were encountered while processing:
       dpkg-dev
       g++-7
       gcc-7
       libasan4:amd64
       libatomic1:amd64
       libcilkrts5:amd64
       libgcc-7-dev:amd64
       libitm1:amd64
       liblsan0:amd64
       libmpx2:amd64
       libquadmath0:amd64
       libstdc++-7-dev:amd64
       libtsan0:amd64
       libubsan0:amd64
       build-essential
       dkms
       g++
       gcc
      dominic@dominic-HP-Laptop-15-db1xxx:~/Desktop/debs$
    Last edited by wildmanne39; 2 Weeks Ago at 03:23 AM. Reason: Added code tags

  8. #28
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    25,131
    Distro
    Ubuntu 19.10 Eoan Ermine

    Re: no wireless for my laptop

    Quite a few of the errors seem to want gcc-8-base 8.3.0-26ubuntu1. Please download and install it and try again.

    I will be off for the evening. I’ll check in tomorrow.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D., Sc.D.

  9. #29
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    28,145
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: no wireless for my laptop

    Please use code tags - if you are using New Reply button - highlight text and use the # button in the text box header.

    If using Quick Reply then [code] at the beginning and [/code] at the end, if you are editing a post to add code tags click the edit button then click the go advanced button, highlight the code then select the # symbol from the tool bar.

  10. #30
    Join Date
    Mar 2020
    Beans
    41

    Re: no wireless for my laptop

    ok will do...should i use pastebin for long text?

Page 3 of 6 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •