Results 1 to 3 of 3

Thread: Locked Bios settings after installing distro

  1. #1
    Join Date
    Mar 2020
    Beans
    1

    Locked Bios settings after installing distro

    After installing a Linux distro(mint 19.3)(yes I know I am in the Ubuntu forum, I'll get to that later) it locked my bios settings - it couldn't boot because it was missing files( I can't change anything, neither restore to default settings, also relocked my secure boot) - picture :

    https://ibb.co/xfkqZrQ
    https://ibb.co/NtfpCwq
    (Majority of options are grey, cannot access them)

    I managed to install a version of Windows and get it boot(after removing the HDD and plugging it while the windows setup was loading, from there I managed to access an Ubuntu live installation usb key using advanced system restart option in windows(the mint one won't boot and neither Manjaro this way, only Ubuntu - secure boot related). Then I installed Ubuntu alongside Windows, now only windows boots. For unlocking the bios settings I also tried( while booting from a live usb without HDD attached) :
    Resetting the CMOS manually - the motherboard has no jumpers, unplugging the battery doesn't work(left it off for 8 hours, it only reset the clock but not other settings
    Deleting the EFI partition - using gparted from Ubuntu - didn't work and I had to reinstall windows again
    Trying sudo modprobe nvram from Ubuntu terminal, commands return no error but it didn't do anything.

    The "EFI file boot 0 :yes" In the second picture is the mint installation that locked my bios settings and then didn't boot, I managed to change boot order from Ubuntu using efibootmgr
    I also deleted the "yes" boot entry but it keeps coming back....

    Now the laptop only boots windows...is there any way I can unlock the BIOS settings?
    Laptop is an Acer es1-531-p7n0

  2. #2
    Join Date
    May 2014
    Location
    /home
    Beans
    8,785
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Locked Bios settings after installing distro

    Moved to proper subforum

  3. #3
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Locked Bios settings after installing distro

    You show UEFI password is set.
    You have to put your password in, to open all the settings including setting "trust" on any boot option other than default Windows.

    Acer Trust Settings - details, some now report that then secure boot has to be on to set trust:
    https://ubuntuforums.org/showthread....2#post13369742 &
    https://ubuntuforums.org/showthread.php?t=2297947 &
    https://ubuntuforums.org/showthread.php?t=2358003
    https://ubuntuforums.org/showthread....7#post13341757
    https://ubuntuforums.org/showthread.php?t=2342323
    Acer Cloudbook shows screen for selecting trust, shows typical screens for all Acer
    http://bernaerts.dyndns.org/linux/74...-cloudbook-431
    https://community.acer.com/en/categories/predator
    Acer Travelmate B117 (success - after some UEFI boot troubles) Trust related
    https://forum.siduction.org/index.php?topic=6272.0

    Many Acer also need UEFI update.
    Acer Very latest UEFI/BIOS works, downgrade not required if no trust screens, you must now upgrade:
    http://ubuntuforums.org/showthread.p...1#post13419141

    Acer ES1-331 laptops Strange differences at new installations
    https://ubuntuforums.org/showthread.php?t=2362511
    Boot Parameter required
    http://askubuntu.com/questions/69580...tu-gnome-15-10

    Acer Aspire ES1-512-C39M Details on supervisor password and settings to enable trust on ubuntu entries Also R14 model same fix
    http://ubuntuforums.org/showthread.p...4#post13203044
    http://acer--uk.custhelp.com/app/ans...le-secure-boot
    http://acer.custhelp.com/app/answers/detail/a_id/29349/
    http://ubuntuforums.org/showthread.php?t=2290594
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •