TL;DR: the first click of the scroll wheel after moving the mouse is ignored in some programs (e.g. chrome and terminal) but not all (e.g. firefox) since at least Ubuntu 16.04 and in Vbox and VMWare.

Hello. Weird mouse problem, as explained in the "TL;DR". This makes scrolling in chrome and the terminal incredibly frustrating, since it's pretty natural to move the mouse some while scrolling and that movement effectively stops the scrolling almost entirely. I ran into this problem years ago and never found a solution, but I did find a post online (even then ancient) about the problem that helped me realize it was the system ignoring the first click of the scroll wheel after a mouse movement. I can replicate that exactly (move the mouse, scroll one click nothing happens, scroll a second click the screen moves).

For years I've just used Debian for virtualization as the problem doesn't happen there. I tried virtualizing Ubuntu (19.10) again today on a Win 10 host with VMWare hoping the problem has been fixed but it hasn't been and makes it really hard to use the system.

I'm not even sure how to begin debugging the problem and could really use some help. If any logs or other info is needed I'm happy to provide them. I have open-vm-tools installed right now, and have had the equivalent tools or additions installed every time in the past that I've had this problem.