Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: M.2 PCIe NVMe hard drive not when trying to install Ubuntu 16.04.6

  1. #11
    Join Date
    Jan 2020
    Beans
    7

    Re: M.2 PCIe NVMe hard drive not when trying to install Ubuntu 16.04.6

    yes, that's probably what I'll do, just update to the earliest version on this machine.

    My need comes from using code by a collaborator (I'm a molecular biologist, not a computer savy person, much less code) in python that stills requires python 2.7 and a bunch of dependencies wrote for Xenial. When using newer versions there is always some package that fails. Thus, I need Xenial. I guess I'll just need to use another machine.

    Thanks for your help.

  2. #12
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: M.2 PCIe NVMe hard drive not when trying to install Ubuntu 16.04.6

    You really need to have the python code updated to version 3.
    Python 2 is obsolete and not being supported anymore.

    https://science.slashdot.org/story/1...lished-studies

    I updated my own python 2 code (small app) by using the converter & then every time it broke, fixed that issue. Lot of google searching as not really a programmer either. The 2to3 conversion tool saved a lot of editing of minor issues like the print statements.

    Python 2 will reach end of life (EOL) on January 1st, 2020
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #13
    Join Date
    Jan 2020
    Beans
    7

    Re: M.2 PCIe NVMe hard drive not when trying to install Ubuntu 16.04.6

    yup, this is a good tip. I should definitely try to convert some things. Although, overall, it's a little more complicated than that, since I run a package (ansible-roles) to install a bunch of "stuff" in a specific conda environment:

    https://github.com/strawlab/strawlab-ansible-roles

    this is the foundational step that breaks down unless I'm using Xenial. The developer definitely wants to update everything, but I guess it does take time and there's many other projects to focus on.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •