Results 1 to 2 of 2

Thread: touchpad problem at random: psmouse serio2: synaptics: Unable to initialize device.

  1. #1
    Join Date
    Sep 2006
    Beans
    1,509
    Distro
    Ubuntu 18.04 Bionic Beaver

    touchpad problem at random: psmouse serio2: synaptics: Unable to initialize device.

    Hello,

    after upgrading to ubuntu 19.10 half of the time I'm getting this error under logs:
    Message psmouse serio2: synaptics: Unable to initialize device.
    Kernel device +serio:serio2
    Priority 3

    The thing is that this is a common issue after also upgrading to 20.04. I'm aware that other users were affected by this issue, yet in my case, this is not happening in every boot, yet it happens at random.

    I always have control of my touchpad, yet in case this error appears, my touchpad is less responsive and I cannot use double finger scrolling or 3 fingers middle click.

    When this error happens, I reboot, and then things are working as normal. Do you have any idea why this happens at random?

    Regards!
    Last edited by Claus7; 1 Week Ago at 03:37 AM.

  2. #2
    Join Date
    Sep 2006
    Beans
    1,509
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: touchpad problem at random: psmouse serio2: synaptics: Unable to initialize devic

    Hello,

    I removed the lightdm window manager and installed gdm, and issue temporarily seemed to get resolved. With the latest updates though, problem persisted. Now, issuing the command:
    dmesg | grep -i psmouse

    I get the output:

    [ 1.809059] psmouse serio2: synaptics: queried max coordinates: x [..5718], y [..4908]
    [ 1.925690] psmouse serio2: synaptics: queried min coordinates: x [1238..], y [956..]
    [ 1.925695] psmouse serio2: synaptics: Your touchpad (PNP: SYN1221 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.
    [ 2.037713] psmouse serio2: synaptics: Unable to initialize device.
    Needs to investigate further...

    edit: according to this: https://forum.manjaro.org/t/touchpad...risis/77353/15, synaptics seems to be obsolete, so I removed it. I rebooted and the output of the previous command is:
    [ 1.807119] psmouse serio2: synaptics: queried max coordinates: x [..5718], y [..4908]
    [ 1.924876] psmouse serio2: synaptics: queried min coordinates: x [1238..], y [956..]
    [ 1.924881] psmouse serio2: synaptics: Your touchpad (PNP: SYN1221 PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to linux-input@vger.kernel.org.
    [ 2.069950] psmouse serio2: synaptics: Touchpad model: 1, fw: 8.2, id: 0x1e2b1, caps: 0xf00223/0x840300/0x26800/0x0, board id: 3175, fw id: 2330500
    The same message for different bus is still there, even if now psmouse is understood.

    edit2:
    1) I re-installed xserver-xorg-input-synaptics, as I saw that this is not affecting anything
    2) typed: sudo gedit /etc/default/grub
    and changed the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.synaptics_intertouch=1"

    do NOT remove quiet splash, unless you would like your login screen to be full of message lines
    3) updated grub with the command: sudo update-grub
    4) rebooted

    Now the output of the command: dmesg | grep -i psmouse, is:

    [ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.4.0-20-generic root=UUID=f38a8643-a1ca-4cf2-81b7-847ab291bc39 ro quiet splash psmouse.synaptics_intertouch=1 vt.handoff=7
    [ 0.031869] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.4.0-20-generic root=UUID=f38a8643-a1ca-4cf2-81b7-847ab291bc39 ro quiet splash psmouse.synaptics_intertouch=1 vt.handoff=7
    [ 1.798411] psmouse serio2: synaptics: queried max coordinates: x [..5718], y [..4908]
    [ 1.915046] psmouse serio2: synaptics: queried min coordinates: x [1238..], y [956..]
    [ 1.915048] psmouse serio2: synaptics: Trying to set up SMBus access
    which seems to be much better. Time will tell how it will behave.

    Regards!
    Last edited by Claus7; 1 Week Ago at 03:44 AM. Reason: adding info

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •