Results 1 to 7 of 7

Thread: HDMI not working in Ubuntu when directly connected, but works with a USB C dock

  1. #1
    Join Date
    Feb 2006
    Beans
    15

    HDMI not working in Ubuntu when directly connected, but works with a USB C dock

    Hello,

    I'm having an unusual problem. If I connect an HDMI monitor directly to my laptop, a Dell Latitude 7280, I don't get any signal. I've tried it in at least three different TVs / interfaces, to no avail. Nothing happens. And at least in one instance Gnome crashed hard.

    BUT I have a powered Dell USB-C dock. I have my HDMI monitor, and a third VGA monitor connected and they all work flawless. The laptop's BIOS is up to date. Thing is, it was working. I gave a presentation on this laptop during the fall last year and it worked. I went to do a presentation last week and it croaked.

    What should I be looking at? I'm 100% in Ubuntu Linux, even for business. I don't want to run back to....Windows.

  2. #2
    Join Date
    Feb 2006
    Beans
    15

    Re: HDMI not working in Ubuntu when directly connected, but works with a USB C dock

    UPDATE: I burned a daily 20.04 LTS beta image to a USB stick and booted the laptop with it and tested it. It works with 20.04.

    I guess I'll have to wait until 20.04 hits.

  3. #3
    Join Date
    May 2013
    Location
    Galiza
    Beans
    1,581
    Distro
    Ubuntu

    Re: HDMI not working in Ubuntu when directly connected, but works with a USB C dock

    You can install it now then keep it updated.

  4. #4
    Join Date
    Feb 2006
    Beans
    15

    Re: HDMI not working in Ubuntu when directly connected, but works with a USB C dock

    I suppose I could. I tend to favor stability, though. I try not to run beta software on my 'production' (day to day) machines. April is about a month away. I'll hold for a couple of weeks.

    Might be a good opportunity to upgrade the SSD on this one too.

  5. #5
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    14,937
    Distro
    Kubuntu 20.04 Focal Fossa

    Re: HDMI not working in Ubuntu when directly connected, but works with a USB C dock

    I've been running Kubuntu 20.04 on a couple of machines for weeks now. Little buggy back toward the end of 2019, but it's pretty rock-solid now.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  6. #6
    Join Date
    Feb 2006
    Beans
    15

    Re: HDMI not working in Ubuntu when directly connected, but works with a USB C dock

    Good to know. My hand may be forced to do it soon.

  7. #7
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    1,035
    Distro
    Xubuntu

    Re: HDMI not working in Ubuntu when directly connected, but works with a USB C dock

    I have been running Xubuntu 20.04 on 3 different machines for the last 2 or 3 months. No issues to speak of.
    Cheers,


    The Linux Command Line at http://linuxcommand.org/

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •