Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 19.10 - Screen blank not working

  1. #1
    Join Date
    Feb 2020
    Beans
    10

    19.10 - Screen blank not working

    Iím new to Ubuntu after having transitioned a desktop away from Windows 10 and Iím having no end of trouble making this work. I just want my screen to turn off after 2 minutes (but keep music playing in the background, for instance) as this is a media PC.

    I am using 19.10 and have these settings in place:
    Power Saving - Blank Screen - 2 minutes
    Screen Lock - Off
    Automatic Login - On

    Is there anything I can do? Thanks for any guidance you can provide!

  2. #2
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,548

    Re: 19.10 - Screen blank not working

    I used your settings in Ubuntu 19.10 (except the automatic login), but it did not stop the music when the screen went blank. What player are you using? Mine is Audacious.

  3. #3
    Join Date
    Feb 2020
    Beans
    10

    Re: 19.10 - Screen blank not working

    Oh thank you for trying! Unfortunately my screen never blanks at all. Iím using Firefox to listen to a stream from classicalradio.com

  4. #4
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,548

    Re: 19.10 - Screen blank not working

    I misunderstood your problem to be that the music stopped when the screen blanked. I tried again using classicalradio.com and I don't get a screen blank. A solution is to open another tab in Firefox, switch to the opened tab, and the screen will go blank and music will continue.

  5. #5
    Join Date
    Feb 2020
    Beans
    10

    Re: 19.10 - Screen blank not working

    What, really? Hah. Okay Iíll give this a try in the morning and report back! Great news if that works. Thank you!

    That being said... is there something I can do to maybe help get this functionality working better? Something about the activity in the tab must be enough for Ubuntu to think thereís interaction. Is this something to do with Firefox? Iíll look up open bugs and see whatís out there.

  6. #6
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,548

    Re: 19.10 - Screen blank not working

    Quote Originally Posted by beguiled View Post
    What, really? Hah. Okay Iíll give this a try in the morning and report back! Great news if that works. Thank you!

    That being said... is there something I can do to maybe help get this functionality working better? Something about the activity in the tab must be enough for Ubuntu to think thereís interaction. Is this something to do with Firefox? Iíll look up open bugs and see whatís out there.
    I guarantee it will work. To see if other streaming sites might be affected, I tested streaming from mixcloud, and the screen blanking worked as expected when streaming some music. The classicradio site had popop messages that might have interfered with the timing for screen blanking.

  7. #7
    Join Date
    Feb 2020
    Beans
    10

    Re: 19.10 - Screen blank not working

    Well, once again, thanks for the tips. It did work, as you stated, so it's definitely to do with the classicalradio.com site. That is odd, though, as you said other sites are not doing it, and this never occurred to me in Windows 10.

    That being said, the functionality isn't the best for my needs now. While the screen does blank, it actually turns off the screen. I use HDMI for my output and when the screen goes blank I lose all video and audio. I was hoping this was more along the lines of setting a screen saver to "blank screen after 2 minutes".

    I had done research into achieving just that and wasn't very impressed with the "screen saver" options in the Ubuntu store. I've been rather surprised at the overall lack of that sort of thing. I was hoping that the OS had a standard "screen saver" that would just simply turn the video off, but not the audio as well. It appears the OS is disabling the port altogether when it blanks the screen.

  8. #8
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    4,548

    Re: 19.10 - Screen blank not working

    Quote Originally Posted by beguiled View Post
    ...While the screen does blank, it actually turns off the screen. I use HDMI for my output and when the screen goes blank I lose all video and audio. I was hoping this was more along the lines of setting a screen saver to "blank screen after 2 minutes".

    I had done research into achieving just that and wasn't very impressed with the "screen saver" options in the Ubuntu store. I've been rather surprised at the overall lack of that sort of thing. I was hoping that the OS had a standard "screen saver" that would just simply turn the video off, but not the audio as well. It appears the OS is disabling the port altogether when it blanks the screen.
    You might get better behavior from installing xscreensaver. That's what I use in Ubuntu. It has "disable" and "blank screen only" options along with the "screensaver" selections. If you try xsceensaver, you must set that other 'blank screen' setting under Settings > Power to 'Never'. That said, I don't use the computer's HDMI output to my monitor, so you would have to test it out.

  9. #9
    Join Date
    Feb 2020
    Beans
    10

    Re: 19.10 - Screen blank not working

    Okay Iíll give that a try as well and report back. Thanks!

  10. #10
    Join Date
    Feb 2020
    Beans
    10

    Re: 19.10 - Screen blank not working

    xscreensaver is the perfect solution for my needs! Itís doing just what I need. Thanks for the great suggestion.

    As an aside, I feel for the developer. I just got done reading his story on his site and had no idea he was so fundamental in the growth of the internet as weíve come to know and love it.

    Anyway, thanks again for your attention to my problem and I appreciate the solution!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •