Results 1 to 6 of 6

Thread: activities bar and title bar on the wrong display

  1. #1
    Join Date
    Mar 2007
    Beans
    705

    activities bar and title bar on the wrong display

    Running 19.10 on an Asus G74SX with a second monitor attached via the VGA port. Works fine in Windows, but in Ubuntu, the activities bar and title bar on on the second moniotr. I've tried going into display settings and sliding the icons around. This changes how Ubuntu thinks my monitors are arranged on my desk (stacked one on top of the other, one on the right, one on the left, etc.), but the system still treats monitor 2 as monitor 1 with regard to the Activities bar (if that is what it's called - the bar at left that contains your favorites icons) and the title bar at the top.

    This is a small issue, really, but still annoying and I would like to fix it.

    Advice most welcome.

    Caruso

  2. #2
    Join Date
    Jan 2006
    Location
    Sunny Southend-on-Sea
    Beans
    7,371
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: activities bar and title bar on the wrong display

    What you're looking for is to set the monitor you're interested in as the primary monitor. By default, that's the first one that the system discovers at boot (screen 0), but it's configurable. In KDE that's simply part of the monitor settings, but I don't know how Gnome handles it.

  3. #3
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    10,870
    Distro
    Ubuntu

    Re: activities bar and title bar on the wrong display

    If using the Join Displays setting then a setting to set the Primary display in under the display setting window (the window you can move the displays around in.)
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  4. #4
    Join Date
    Mar 2007
    Beans
    705

    Re: activities bar and title bar on the wrong display

    I appreciate the replies, but the suggestions are not working for me. This never used to be a problem. I do not know what has changed.
    Caruso

  5. #5
    Join Date
    Apr 2007
    Beans
    2,863
    Distro
    Ubuntu

    Re: activities bar and title bar on the wrong display

    In standard Ubuntu, go to Settings, Displays. With the "Join Displays" active (i.e. different content on the two screens), change the "Primary Display" setting to the monitor where you want the Gnome Shell controls to appear.

  6. #6
    Join Date
    Mar 2007
    Beans
    705

    Re: activities bar and title bar on the wrong display

    I have it set this way. On my system, display 1 is described as built-in display (my laptop's screen), and is set as the Primary Display. Display 2 is described as Samsung 19" . . . (that's my VGA monitor). This all appears to be correct, except that the "controls" are displaying on Display 2, not Display 1.

    So, something is not working correctly.

    Thanks for your reply.

    Caruso

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •